Projektrechner "Back to the roots"

Bilder von Geräten, Projekten und Sammlerstücken der Forenmitglieder
Antworten
Benutzeravatar
Dark_Lord
Kommandozeilenfetischist
Beiträge: 174
Registriert: So 25. Mai 2008, 19:44
Wohnort: Nähe Köln
Kontaktdaten:

Projektrechner "Back to the roots"

Beitrag von Dark_Lord »

​Hallo zusammen,

hier schon mal ein paar Hintergrundinfos über einen künftigen Projektrechner. Sobald sich das Ding realisiert (vermutlich Februar/März) gibt es dazu auch Bilder und vermutlich auch einen Beitrag auf Youtube. "Der Gerät" soll ein wenig angelehnt an meinen ersten PC sein, ein Sanyo MBC-990 286-8. Er wird aber in einigen Belangen deutlich überlegen, aber nah dran. Wichtig war mir deshalb auch ein Desktop-Gehäuse.

Ich hab schon länger auf dem Prioritäten-Tisch mein 286-Board liegen. Da kämpfe ich noch mit der zu schnell laufenden RTC.

Dann ist mir auf Ebay Kleinanzeigen ein neues, noch originalverpacktes Leadman LC-402 Desktop-Gehäuse (mit nach oben klappender Haube!) zugeflogen, direkt gebunkert. Das verbaute Leadman-Netzteil hat original ab Werk keinen Lüfter verbaut. 60 Watt geht wohl auch ohne. Da eine CF-Karte rein soll, wird es wohl ein Silent Build.

Was soll rein und wie ist das im Vergleich zu meinem ersten PC, dem Sanyo?

Gehäuse:
- Sanyo hatte: Breiten Desktop mit IBM Style Netzteil (mit rotem Kipphebel-Schalter und brutal lautem Lüfter)
- Der neue hat: Etwas schmaleren Desktop mit ähnlichem Netzteil (aber schwarzem Kippschalter, der aber immer noch schön satt klackt, lüfterlos)

Board/CPU:
- Sanyo hatte: Fullsize AT Board mit 512KB Onboard RAM und 128KB über ISA-Karte, 286-8, Coprozessor-Sockel
- Der neue hat: Baby AT Board (Headland HT12), 4x 1MB SIMM 70ns 30 Pin, 286-16 und 287-8 (läuft übertaktet auf 10MHz)

Grafikkarte:
- Der Sanyo hatte: EGA-Grafikkarte
- Der neue hat: Tseng Labs ET3000AX (Aufkleber sagt NKS mpvgamax), 512KB S-VGA mit VGA und TTL Anschluss (so eine hatte ich auch in meinem 386SX nach dem Sanyo)

Diskettenlaufwerke:
- Der Sanyo hatte: 5.25" 1.2MB (A), 3.5" 1.44MB (B)
- Der neue hat: Genau so!

Festplatte:
- Der Sanyo hatte: 30MB MFM
- Der neue hat: Digitus CF zu IDE auf Slotbracket (hinten von außen zugänglich), Xmore Industrial CF 256MB, SLC NAND-Flash (nutze die gleiche auch in meinem Commodore PC-20 im XT-CF Lite)

CD-ROM:
Der Sanyo hatte: Keines
Der neue hat: Mitsumi CRMC-LU005S (das erste Single-Speed, das auf einem Schlitten ganz aus dem Käfig rauskam und dann Klappe auf, Toploader-Mechanismus)

Soundkarte:
- Der Sanyo hatte: Keine. PC-Speaker Experience in Reinkultur!
- Der neue hat (hoffentlich, gerade zufällig beim Aufräumen gefunden, Test steht noch aus): Aztech Sound Galaxy NX II (alias CPS SoundBlaster 2.5)

Tastatur:
- Der Sanyo hatte: AT-Tastatur im XT-Layout (84 Tasten)
- Der neue hat: Cherry G80-1000HAD (Linear)

Maus:
- Der Sanyo hatte: Anfänglich keine, später die eckige alte Genius 3-Tasten Maus (würde ich, wenn günstig zu finden, auch noch mal eine holen)
- Der neue hat: Highscreen Colani Maus, die ich auch am PC-20 nutze

Bildschirm:
- Der Sanyo hatte: EGA-Monitor Salora Multiscan
- Der neue hat: Fürs Foto wird es wohl mein zweiter Monitor (der nach dem Sanyo mit dem 386SX kam), ein NEC Multisync II, im Alltag wohl eher an einem meiner LCDs (Fujitsu-Siemens P19-2, Dell Ultrasharp U2711), da der NEC einige Macken hat (dass er, wenn er warm ist, eine halbe Stunde abkühlen muss, bis er wieder angeht, hatte er schon immer, war damals ein Gebrauchtkauf, aber mittlerweile braucht er auch eine halbe Stunde Einlaufzeit um scharf zu werden, dann ist er aber auch scharf)
Arbeitspferde: Xeon E5-2683v3 und Q6600

Retro:
P2-450
Commodore PC20-II/Tandy Sound
286/ET3000/Aztech NX-II
Amiga 500/Gotek/Vortex AT-once Plus 286
Pentium 166/FAST Video Machine

Projekt-PCs: C64, Dual Pentium MMX 233, 486 VLB, 486 PCI, K6, Athlon 64
Projekte: USB RetroArduInput
Benutzeravatar
jaquamala
MemMaker-Benutzer
Beiträge: 50
Registriert: Fr 15. Mai 2020, 13:04

Re: Projektrechner "Back to the roots"

Beitrag von jaquamala »

Ein 286er war auch mein erster PC :-) Damals ein Highscreen Serie 2. Ich habe vor kurzen in dem gleichen Gehäuse von Leadman mit dem 60 Watt Netzteil ein 286er Build umgesetzt. In meiner Konfiguration waren die 60 Watt ausreichend. Mit Mainboard, Sound-, Controller-, VGA-, Gameportkarte und CF Adapter kam ich im Idle auf ca. 20 Watt. Wenn eines der beiden Diskettenlaufwerke lief dann waren es ca. 25 Watt. Ein CD-ROM Laufwerk hatte ich nicht verbaut. Ein 286er mit CF Karte und mit diesem Netzteil ist ein super Silent PC. Viel Spaß beim bauen!
AMD 5x86-133MHz, 32MB FPM RAM, Number Nine T2R PCI 4MB WRAM + 4MB Modul, Terratec Maestro 32/96 + Dreamblaster X2, Pioneer 32x Slot In, 3,5" + 5,25" FDD, 8GB CF als HDD
Benutzeravatar
Dark_Lord
Kommandozeilenfetischist
Beiträge: 174
Registriert: So 25. Mai 2008, 19:44
Wohnort: Nähe Köln
Kontaktdaten:

Re: Projektrechner "Back to the roots"

Beitrag von Dark_Lord »

Spaß werde ich haben. Leider gibt es noch zwei Hürden zu überwinden und dazu habe ich aufgrund von vielen Dienstreisen (innerdeutsch, aber nicht zuhause ist nicht zuhause) unter der Woche nicht angehen kann. Erstens hat das Mainboard eine Macke (ich muss noch einen Ersatz für den entfernten Tonnenakku installieren und die RTC läuft auf einer absurden Geschwindigkeit, 15-16 Sekunden pro Sekunde) und auch die Soundkarte hatte ich noch mal kurz angetestet und sie wird nicht erkannt (Chips werden alle normal warm, allerdings habe ich den Crystal nicht berührt, hatte schon mal wo anders von einem gelesen, wo der auf einer normalen NX defekt war und extrem heiß wurde, vielleicht ist es aber auch das, was das Installationsprogramm sagt, ein Ressourcenkonflikt)
Arbeitspferde: Xeon E5-2683v3 und Q6600

Retro:
P2-450
Commodore PC20-II/Tandy Sound
286/ET3000/Aztech NX-II
Amiga 500/Gotek/Vortex AT-once Plus 286
Pentium 166/FAST Video Machine

Projekt-PCs: C64, Dual Pentium MMX 233, 486 VLB, 486 PCI, K6, Athlon 64
Projekte: USB RetroArduInput
S+M
DOS-Guru
Beiträge: 956
Registriert: Mo 10. Jun 2013, 17:04
Wohnort: BW

Re: Projektrechner "Back to the roots"

Beitrag von S+M »

Ressourcenkonflikt ist zumindest in einem gut bestückten System sicherlich einer der häufigsten Ursachen :like:

Hübsches altes System, das war noch die Zeit, als man Systeme komplett passiv betreiben konnte, heute geht's ja wieder :-)
Benutzeravatar
Dark_Lord
Kommandozeilenfetischist
Beiträge: 174
Registriert: So 25. Mai 2008, 19:44
Wohnort: Nähe Köln
Kontaktdaten:

Re: Projektrechner "Back to the roots"

Beitrag von Dark_Lord »

In dem Fall jedoch vermutlich nicht... der 12MHz Oszillator auf der Karte oszilliert nicht. Bleibt zwar kühl, aber kommt nix raus.

Hätte notfalls noch eine Opti-Karte (Trontec 201 a.k.a. MAD-16), aber die ist mir eigentlich zu modern (nicht passend für die Ära) und ich würde gerne mal die Covox-Emulation der Aztech testen. Außerdem ist die Aztech ja schon Kult.

An dem Mainboard habe ich noch mal etwas mit dem Oszilloskop gemessen.

Der Ausgang des Oszillators geht erst mal auf einen HEF4069UBP, einen Inverter-Baustein. Was aus dessen Ausgang (Pin 4), der direkt auf den Clock-Eingängen Clk1 (Pin 2) der RTC geht, ist ziemlich zerwürfelt (Clk2 (Pin 3) sieht ähnlich zerwürfelt aus). Letztlich ist es der gleiche Takt, der auch aus dem Oszillator kommt, aber nach der steigenden Flanke fällt es noch mal kurz ab und nach der fallenden Flanke steigt es noch mal an. So geht es in die RTC rein und so kommt es aus dem Clock out der RTC auch wieder raus.

Jetzt wird es aber lustig: An Pin 6 des HEF4069UBP liegt ein sauberes Taktsignal an. Wenn ich nun die Probe für Channel 2 des Oszilloskops an Pin 6 halte, wird das Signal an Pin 4 auch sauber und die Clock zählt sauber. Nehme ich die Probe wieder weg, habe ich auch wieder ein zerwürfeltes Clock-Signal samt zu schnell (random 2, 3 oder die ursprünglichen 15 Sekunden pro Sekunde) zählender Uhr.
Arbeitspferde: Xeon E5-2683v3 und Q6600

Retro:
P2-450
Commodore PC20-II/Tandy Sound
286/ET3000/Aztech NX-II
Amiga 500/Gotek/Vortex AT-once Plus 286
Pentium 166/FAST Video Machine

Projekt-PCs: C64, Dual Pentium MMX 233, 486 VLB, 486 PCI, K6, Athlon 64
Projekte: USB RetroArduInput
S+M
DOS-Guru
Beiträge: 956
Registriert: Mo 10. Jun 2013, 17:04
Wohnort: BW

Re: Projektrechner "Back to the roots"

Beitrag von S+M »

Ist da ein Kondensator kaputt (kalte Lötstelle?) durch deinen Tastkopf bringst du zusätzliche Kapazität ins System und kannst damit den Schwingkreis stabilisieren.
Benutzeravatar
Dark_Lord
Kommandozeilenfetischist
Beiträge: 174
Registriert: So 25. Mai 2008, 19:44
Wohnort: Nähe Köln
Kontaktdaten:

Re: Projektrechner "Back to the roots"

Beitrag von Dark_Lord »

So, die Kiste ist zusammengebaut, Bilder kommen bei Gelegenheit noch. Ich hab noch einen kleinen Keramikkondensator zwischen das Beinchen, an dem ich den Tastkopf anliegen hatte und Masse angelötet, da ich keine weiteren defekten Traces gefunden habe und auch die Keramikkondensatoren im Schwingkreis okay sind (hab sie einfach mal gegen welche gleichen Typs getauscht.

Eigentlich wollte ich den Zusammenbau ja sogar filmen für Youtube, aber da ich im Moment zu nix größerem in Sachen Projekt komme und mir die losen Teile auf den Senkel gegangen sind, habe ich alles zusammengebaut. Zusammenbau so ist ja schneller getan, als vor der Kamera. Vielleicht baue ich ihn für Youtube abernoch mal auseinander wenn ich was mehr Zeit und Muße zum Filmen habe :-) Bilder und auf kurz oder lang ein Video kommen noch.

Nur die Soundkarte foppt mich echt. Ich hatte während meiner fliegend verkabelten Tests immer gedacht, mein Mitsumi CD-ROM wäre nicht mehr ganz frisch, da es nur mehr oder weniger zuverlässig gearbeitet hat. Allerdings hatte ich das Laufwerk an eben dieser Sound Galaxy NX2 angeschlossen. Und nach dem Zusammenbau wollte die Soundkarte dann keinen Ton mehr ausgeben, wenn das CD-ROM angeschlossen war.

Heute hatte ich das Gerät noch mal eingeschaltet, eigentlich um mal ein paar alte Disketten durchzugucken. Das System hat sich dann relativ seltsam verhalten. Der POST läuft erst ganz normal (Speicherzählen-Ticken vom AMI-BIOS, Floppy Drive Seek, dann hört man aus dem Line Out der Soundkarte das Knacken (vermutlich weil der Parallelport vom integrierten Covox initialisiert) und ab dann wird es langsam. Der BIOS-Bildschirm bleibt lange stehen, dann kommt ein ewig-langer Bestätigungs-Beep und dann baut sich zeilenweise die BIOS-Zusammenfassung auf. Der Schuldige war schnell als Soundkarte identifiziert. Jetzt ist die MAD-16 drin, eigentlich ja viel zu modern für den Rechner, aber sie läuft und hat ein Mitsumi-Interface, mit dem das CD-ROM sogar absolut sauber läuft. Ich denke aber auf kurz oder lang werde ich die NX2 noch etwas debuggen, die Karte hat was und lief bislang recht vielversprechend. Vor allem die Covox-Unterstützung finde ich spannend und sie passt zeitlich zum 286. Die MAD-16 hätte ich zudem gerne in einem moderneren System wie einem meiner Projekt-486er.
Arbeitspferde: Xeon E5-2683v3 und Q6600

Retro:
P2-450
Commodore PC20-II/Tandy Sound
286/ET3000/Aztech NX-II
Amiga 500/Gotek/Vortex AT-once Plus 286
Pentium 166/FAST Video Machine

Projekt-PCs: C64, Dual Pentium MMX 233, 486 VLB, 486 PCI, K6, Athlon 64
Projekte: USB RetroArduInput
Benutzeravatar
Dark_Lord
Kommandozeilenfetischist
Beiträge: 174
Registriert: So 25. Mai 2008, 19:44
Wohnort: Nähe Köln
Kontaktdaten:

Re: Projektrechner "Back to the roots"

Beitrag von Dark_Lord »

​Anbei mal ein paar Bilder.

Zu sehen sind:

Frontansicht des Gerätes
Mitsumi LU-005S CD-ROM geöffnet
Rückseite Anschlüsse
Innenraum Großaufnahme (Kabelmanagement noch ausstehend, aber auch gar nicht so einfach, u.A. wäre viel leichter, die Floppys vernünftig zu verkabeln, wenn man das 3.5" Laufwerk 180° drehen könnte)
Gesamtansicht offener Gehäusedeckel (schöner Klappmechanismus)
Die temporär eingebaute Soundkarte (MAD-16 mit roter Platine)
Die Soundkarte, die ich gerne drin hätte, die aber ständig irgendwelche Probleme macht (CPS Sound Blaster 2.5 a.k.a. Aztech Sound Galaxy NX II)
Die ET3000 Grafikkarte
Die Realtek RTL8019 Netzwerkkarte (nur aus Spaß eingebaut weil noch da)
Der MIO-Plus Multi-IO Controller. Ein paar Pins der IO-Header sind etwas verbogen, weil ich das Ding recht achtlos in eine Kiste gepfeffert hatte, läuft aber einwandfrei. Ich muss nur noch das I/O Shield für Parallel und vor allem Joystick finden (weil man den Joystick-Port nicht abschalten kann und es einen Konflikt mit dem auf der Soundkarte gibt, den müsste ich dann abschalten)
Der Digitus Compact Flash Adapter samt

Hier https://books.google.de/books?id=5hdeC0 ... 90&f=false (das linke Bild) gibt es übrigens ein Bild von meinem allerersten PC, dem Sanyo MBC-990, an den das Gerät, mit einer gewissen Überlegenheit erinnern soll.
Dateianhänge
01-Front.jpg
01-Front.jpg (74.87 KiB) 115 mal betrachtet
02-CD-ROM.jpg
02-CD-ROM.jpg (82.02 KiB) 115 mal betrachtet
03-Rückseite.jpg
03-Rückseite.jpg (101.47 KiB) 115 mal betrachtet
04-Innen groß.jpg
04-Innen groß.jpg (122.56 KiB) 115 mal betrachtet
05-Klappe auf.jpg
05-Klappe auf.jpg (90.65 KiB) 115 mal betrachtet
06-Temporäre Soundkarte.jpg
06-Temporäre Soundkarte.jpg (148.9 KiB) 115 mal betrachtet
07-Problematische Soundkarte.jpg
07-Problematische Soundkarte.jpg (148.75 KiB) 115 mal betrachtet
08-ET3000 Grafik.jpg
08-ET3000 Grafik.jpg (153.04 KiB) 115 mal betrachtet
09-Realtek Netzwerk.jpg
09-Realtek Netzwerk.jpg (113.79 KiB) 115 mal betrachtet
10-MIO-Plus Multi-IO.jpg
10-MIO-Plus Multi-IO.jpg (134.56 KiB) 115 mal betrachtet
11-CF-Adapter.jpg
11-CF-Adapter.jpg (100.83 KiB) 115 mal betrachtet
Arbeitspferde: Xeon E5-2683v3 und Q6600

Retro:
P2-450
Commodore PC20-II/Tandy Sound
286/ET3000/Aztech NX-II
Amiga 500/Gotek/Vortex AT-once Plus 286
Pentium 166/FAST Video Machine

Projekt-PCs: C64, Dual Pentium MMX 233, 486 VLB, 486 PCI, K6, Athlon 64
Projekte: USB RetroArduInput
Antworten