Laute CD-Laufwerke unter DOS - Abhilfe mit CDBeQuiet!

Diskussion zum Thema Programmierung unter DOS (Intel x86)
Benutzeravatar
Kurt Steiner
DOS-Guru
Beiträge: 906
Registriert: Mo 14. Dez 2009, 08:05
Wohnort: Leipzig

Re: Laute CD-Laufwerke unter DOS - Abhilfe mit CDBeQuiet!

Beitrag von Kurt Steiner »

Cool jetzt gehen auch Werte unter 1200 bei meinem Laufwerk aber leider nimmt er sie dann nicht weiter, außer 600 !!!

Werte 75, 150, 300 haben keinen Einfluss und bekommen die gleichen Werte wie 600 bzw. sogar 1200 !
Mir ist aufgefallen, dass nicht mit jeder CD das Programm arbeiten kann, ich hatte von Ripper 1CD drinn,
da ging es nicht, jetzt ist andere CD drinn und es geht.

1800 - 10.75x Speed - 83,75 Punkte:
1800.jpg
1800.jpg (106.11 KiB) 16256 mal betrachtet
600 - 14,35x Speed - 131,34 Punkte:
600.jpg
600.jpg (106.88 KiB) 16257 mal betrachtet
1200 - 18,62x Speed - 171,30 Punkte:
1200.jpg
1200.jpg (107.43 KiB) 16257 mal betrachtet




PS: Kleiner Schreibfehler:

Example:
If you wanted to set a CD speed of 4x (1x = 150 kb/s)
for a slave CD-ROM on your secondary IDE channel,
the following command will do:
cdbq -p2 -dm -s600


Müsste: cdbq -p2 -ds -s600 heißen ! Da es Slave ist.
Benutzeravatar
ChrisR3tro
Administrator
Beiträge: 1975
Registriert: Mo 7. Mär 2005, 23:33
Wohnort: NRW
Kontaktdaten:

Re: Laute CD-Laufwerke unter DOS - Abhilfe mit CDBeQuiet!

Beitrag von ChrisR3tro »

Hey Kurt,

danke für die Infos, insbesondere den Tippfehler. In der Version 1.0 werde ich das verbessern.

Dein Laufwerk zeigt ja komische Werte. Bei 1800 nur 10.75x? War das mit CDBQ 0.7b anders? Wenn ja würd' ich dich bitten, das nochmal genau nachzuvollziehen. Denn eigentlich darf sich in den Ergebnissen nichts unterscheiden zwischen den Versionen...

Hast du mit Rohlingen oder mit "echten" CDs getestet? (Besser ist mit echten, unverkratzten, vollbeschriebenen CDs)

Gruß
locutus
Benutzeravatar
Kurt Steiner
DOS-Guru
Beiträge: 906
Registriert: Mo 14. Dez 2009, 08:05
Wohnort: Leipzig

Re: Laute CD-Laufwerke unter DOS - Abhilfe mit CDBeQuiet!

Beitrag von Kurt Steiner »

Hallo locutus,

jupp werde heute Abend noch mal beide Versionen testen.

Ist eine originale Spiele-CD gewesen. Wie gesagt mit der Spiele-CD 1 von Ripper hatte ich dieselben Werte als wenn ich keine CD-Bremse drinne hätte.

Ich nehme heute Abend wieder die eine CD und werde 4 Tests machen einmal 1200 mit beiden Versionen und dann noch mal mit 1800. Bin mal gespannt ob die sich unterscheiden. Den ersten Test auf Seite 4 habe ich mit einer anderen CD gemacht die nicht größer als 510 MB war, deswegen fehlen da auch die Seek-Werte.
Benutzeravatar
Kurt Steiner
DOS-Guru
Beiträge: 906
Registriert: Mo 14. Dez 2009, 08:05
Wohnort: Leipzig

Re: Laute CD-Laufwerke unter DOS - Abhilfe mit CDBeQuiet!

Beitrag von Kurt Steiner »

Oki hier nochmal die Werte: Test-CD war die erste Spiele-CD (org.) von Blade Runner. Bei jeden Neueinstellen der Geschwindigkeit wurde gebootet.

V.07 - 1200 - 19.74x Speed - 213,63 Punkte:
V7_1200.jpg
V7_1200.jpg (106.14 KiB) 16229 mal betrachtet
V.09 - 1200 - 19.85x Speed - 227,30 Punkte:
V9_1200.jpg
V9_1200.jpg (105.64 KiB) 16229 mal betrachtet
V.07 - 1800 - 10.81x Speed - 98,94 Punkte:
V7_1800.jpg
V7_1800.jpg (105.44 KiB) 16229 mal betrachtet
V.09 - 1800 - 10.81x Speed - 98,98 Punkte:
V9_1800.jpg
V9_1800.jpg (105.54 KiB) 16229 mal betrachtet

PS: Andere Werte die getestet wurden waren, 2150, 2400, 3600 alle Werte keinen nennenswerten Effekt !
Benutzeravatar
ChrisR3tro
Administrator
Beiträge: 1975
Registriert: Mo 7. Mär 2005, 23:33
Wohnort: NRW
Kontaktdaten:

Re: Laute CD-Laufwerke unter DOS - Abhilfe mit CDBeQuiet!

Beitrag von ChrisR3tro »

Danke für die Tests! Die sind jetzt etwas aufschlußreicher. Gut auch, daß du jedesmal rebootet hast.

Die Ergebnisse von 0.7 vs 0.9 unterscheiden sich nicht, was schonmal gut ist. D.h., daß der neue Code aus 0.9b gut funktioniert. Ich hatte erst befürchtet, daß es da Unterschiede geben könnte.

Außerdem sieht man an der ersten Grafik recht deutlich, daß dein Laufwerk bei ~24x Schluß macht.

Mich wundert jetzt etwas, daß nur Werte zwischen 1800 und 2150 einen Effekt haben, aber was soll's. Manche Laufwerke sind da akkurater und andere interpretieren den Wert relativ ungenau bis gar nicht. Mein TEAC-Laufwerk nimmt die Werte ziemlich genau, das liegt aber vielleicht auch daran, daß TEAC bei ihrem eigenen DOS-CD-ROM-Treiber schon von Hause aus eine Geschwindigkeitsbegrenzung vorgesehen hat (über einen Parameter), welche anscheinend dieselbe Methode nutzt wie CDBQ.

Kannst du evtl. noch die Firmware-Revision posten?

Danke

locutus
Benutzeravatar
Kurt Steiner
DOS-Guru
Beiträge: 906
Registriert: Mo 14. Dez 2009, 08:05
Wohnort: Leipzig

Re: Laute CD-Laufwerke unter DOS - Abhilfe mit CDBeQuiet!

Beitrag von Kurt Steiner »

Also 600/1800 habe verschiedene Werte, ich komme mit den 1800 am besten und geht auch ganz gut !

Model number: TSSTcorpDVD-ROM SH-D162D
Firmware rev.: SB03

(Steht schon in deiner Liste drinne.)

ich werde mal noch andere Werte im laufe der Zeit testen. Mal schauen ob ich die Kiste unter 10x bekomme.

1200 hat keinen EFFEKT !!!

Ohne CDBremse - 19.75x Speed - 213,83 Punkte:
ohne_bremse.jpg
ohne_bremse.jpg (106.29 KiB) 16225 mal betrachtet
Benutzeravatar
ChrisR3tro
Administrator
Beiträge: 1975
Registriert: Mo 7. Mär 2005, 23:33
Wohnort: NRW
Kontaktdaten:

Re: Laute CD-Laufwerke unter DOS - Abhilfe mit CDBeQuiet!

Beitrag von ChrisR3tro »

Hallo Leute,

wollte euch nur wissen lassen, dass es nach 6 Jahren jetzt wieder eine neue Version gibt. :-)

Grundsätzlich hat sich nur geändert, dass jetzt kein DPMI-Speicher mehr benötigt wird.

Gruß
locutus
Benutzeravatar
Kurt Steiner
DOS-Guru
Beiträge: 906
Registriert: Mo 14. Dez 2009, 08:05
Wohnort: Leipzig

Re: Laute CD-Laufwerke unter DOS - Abhilfe mit CDBeQuiet!

Beitrag von Kurt Steiner »

Ohh "gerade" gesehen - gleich mal am Sonntag testen...

Danke
Benutzeravatar
ChrisR3tro
Administrator
Beiträge: 1975
Registriert: Mo 7. Mär 2005, 23:33
Wohnort: NRW
Kontaktdaten:

Re: Laute CD-Laufwerke unter DOS - Abhilfe mit CDBeQuiet!

Beitrag von ChrisR3tro »

Hi zusammen!

Ich habe mir letztens zwei Pioneer-DVD-ROM-Laufwerke gekauft, undzwar welche mit Slot-In-Mechanismus:
  • Pioneer DVD-120S
  • Pioneer DVD-A06S/106S
Bilder findet ihr im Netz. Finde das Design dieser Laufwerke relativ schön wegen dem Slot-In-Mechanismus. Das A06 ist älter, aber scheint besser verarbeitet zu sein. Ist ja oft so, dass im Laufe der Jahre Kosten reduziert werden zu Lasten der Qualität.

Leider muss ich euch mitteilen, dass das nötige ATA-Kommando zum Setzen der Max-Geschwindigkeit nicht unterstützt wird. CDBQ kann das Kommando zwar absetzen, aber beide Laufwerke zeigen überhaupt keinen Effekt. Verifizieren konnte ich das mit dem TEAC-CD-ROM-Treiber für DOS, der ebenfalls dieses Kommando absetzen kann wenn er geladen wird - hier ebenfalls kein Effekt.

Schade...

Gruß
Christoph
Benutzeravatar
schlang
DOS-Guru
Beiträge: 503
Registriert: Di 23. Dez 2008, 04:56
Wohnort: Medellin

Re: Laute CD-Laufwerke unter DOS - Abhilfe mit CDBeQuiet!

Beitrag von schlang »

Hab nur schlechte Erinnerungen an mein Pioneer DVD-120S. Design wunderbar aber die Lesbarkeit von Rohlingen war unter aller Kanone
PC#1: K6-III+ 400 | 512MB | Geforce4 | Voodoo1 | SB Live | AWE64 | GUS PNP Pro
PC#2: 486DX2-66 | 64MB | Riva128 | AWE64 | GUS PNP | PAS16
PC#3: 386DX-40 | 32MB | CL-GD5434 | SB Pro | GUS MAX | PAS16
MIDI: MT-32 | SC-55 | Mu-50
Benutzeravatar
ChrisR3tro
Administrator
Beiträge: 1975
Registriert: Mo 7. Mär 2005, 23:33
Wohnort: NRW
Kontaktdaten:

Re: Laute CD-Laufwerke unter DOS - Abhilfe mit CDBeQuiet!

Beitrag von ChrisR3tro »

Hi Leute. Wollte euch nur wissen lassen - es gibt wieder eine verbesserte Version (1.2) und die Adresse der Projektseite hat sich geändert. Viel Spaß!
Für mehr Retro-Kram schaut gerne mal auf X vorbei unter @ChrisR3tro.
Kordanor
HELP.COM-Benutzer
Beiträge: 29
Registriert: Fr 30. Dez 2022, 21:13

Re: Laute CD-Laufwerke unter DOS - Abhilfe mit CDBeQuiet!

Beitrag von Kordanor »

Heyho,
danke erstmal für das Tool.
Ich habe es nun mal auf meinem 52x CD Laufwerk modell LTN-526D getestet, aber leider bewirkt es nicht viel.
Im Moment, wo man es setzt, ändert sich die Idle-Gewhschwindigkeit, aber auch nicht immer nach unten. Manchmal wirds sogar lauter/schneller, wenn man es langsamer setzt. Aber beim Benchmark sind die Ergebnisse immer gleich. Der letzte Graph sieht zwar anders aus, das liegt aber nur am Skala-Wechsel wie es aussieht. Die Werte sind gleich.

Getestet:
At Max Setting
LTN-526D - Max.png
LTN-526D - Max.png (144.39 KiB) 4875 mal betrachtet
at 1800
LTN-526D - 1800.png
LTN-526D - 1800.png (140.96 KiB) 4875 mal betrachtet
at 600
LTN-526D - 600.png
LTN-526D - 600.png (155.11 KiB) 4875 mal betrachtet
Kordanor
HELP.COM-Benutzer
Beiträge: 29
Registriert: Fr 30. Dez 2022, 21:13

Re: Laute CD-Laufwerke unter DOS - Abhilfe mit CDBeQuiet!

Beitrag von Kordanor »

Als nächstes habe ich ein 40x Laufwerk Pan-International, Model 400D getestet:
Das Interessante hier, ist dass das Laufwerkt im Idle Speed grundsätzlich deutlich lauter ist als im Benchmark.
Ich hab da extra vorher nochmal rebootet und dann auch noch die geschwindigkeit mit S0 auf maximum gesetzt.
Im Benchmark ist das Laufwerk sehr leise. Ich bin mir nicht sicher, wie überhaupt die 25x werte usw im Benchmark zu werten sind, da die Laufwerkangaben ja mal komplett anders sind (das 50x Laufwerk war bei 25.56 max, und das 40 fach bei nichtmal 20x max). Krass ist auch wieso dieses zweite Laufwerk einen so viel sauberen Graphen abgibt.
Das Pan-International hatte ausserdem am Ende eine "Unstable Read Zone und eine Fatal Error Zone"

Beim Test auf 600 gab es diese Fehler ebenfalls.
Als ich dann nach den Fehlern mal eine andere CD (PC Player 2/96 ausgetauscht mit PC Player 1/96) ausprobiert habe (Analyseprogramm laufen gelassen, nur CD gewechselt) hat das Laufwerk dann voll aufgedreht, war recht laut, und hat die alte Einstellung wieder vergessen. Allerdings war die CD nicht voll genug für den vollen Test.
Ich habe dann die Gamestar 12/99 eingelegt. Die ist voll, und lustigerweise ist das dann wieder runtergewechselt und war wieder super leise.
Wieder die PC Player mit wenig Kapazität rein, und wieder super laut. Nochmal raus und wieder rein, immer noch laut.

Also dieses Drive scheint nur dann die Geschwindigkeit anzunehmen, wenn ihm danach ist.
Model400D - Max.png
Model400D - Max.png (136.06 KiB) 4871 mal betrachtet
Model400D - 600 PCPlayer1.png
Model400D - 600 PCPlayer1.png (137.1 KiB) 4871 mal betrachtet
Model400D - 600 Gamestar.png
Model400D - 600 Gamestar.png (132.24 KiB) 4871 mal betrachtet
Model400D - 600 PCPlayer Small.png
Model400D - 600 PCPlayer Small.png (138.46 KiB) 4871 mal betrachtet
Benutzeravatar
ChrisR3tro
Administrator
Beiträge: 1975
Registriert: Mo 7. Mär 2005, 23:33
Wohnort: NRW
Kontaktdaten:

Re: Laute CD-Laufwerke unter DOS - Abhilfe mit CDBeQuiet!

Beitrag von ChrisR3tro »

Hi Kordanor und erstmal danke für die vielen Tests. Zunächst mal ein paar grundlegende Dinge:

Ich hoffe, du testest mit der aktuellen Version von CDBeQuiet!, diese ist 1.2. Die Geschwindigkeitsangaben der Hersteller (48x, 52x, ...) sind zum Teil maßlos übertrieben. Darauf würde ich nicht all zuviel geben. Mir persönlich ist auch vollkommen egal, ob eine CD in 3 min oder in 10 min ausgelesen wird, Hauptsache das Ding ist nicht unerträglich laut und die Datenrate ist stabil.

Am besten testet man die Lesegeschwindigkeit und die Lautstärke mit einer originalen Daten-CD, ohne Multi-session, Audiospuren oder sonstigen Besonderheiten. Zudem sollte die Disc unverkratzt sein, denn nur dann kann man verläßliche Ergebnisse erzielen.

Nun zu deinen Laufwerken: Zum Lite-On-Laufwerk muss ich dir leider mitteilen, dass es nicht kompatibel ist mit CDBeQuiet! und das wundert mich auch nicht, weil schon andere Laufwerke dieses Herstellers in der Liste der nicht-unterstützten Modelle auftauchen.

Das zweite scheint immerhin auf das SET CD SPEED - Kommando zu reagieren. Manche Laufwerke "vergessen" allerdings die Einstellung sobald man die CD wechselt.

Bitte teile mir von beiden Laufwerken die Details mit, dann kann ich sie in die Liste der getesteten Laufwerke mit aufnehmen. Herausfinden kannst du Modell und Firmware über den Befehl cdbq -p1 -dm -i. (-p und -d sind natürlich entsprechend anzupassen).

Viele Grüße
ChrisR3tro
Für mehr Retro-Kram schaut gerne mal auf X vorbei unter @ChrisR3tro.
Kordanor
HELP.COM-Benutzer
Beiträge: 29
Registriert: Fr 30. Dez 2022, 21:13

Re: Laute CD-Laufwerke unter DOS - Abhilfe mit CDBeQuiet!

Beitrag von Kordanor »

Heyho,
jau, habe die aktuelle version verwendet.

das Liteon ist:
Model number: LTN526D
Firmware rev.: YSR5

Beim Pan-International, Model 400D kommt folgendes:
Model number: ATAPI CDROM
Firmware rev.: V110
Antworten