Dallas RTC Umbau - Erfahrungsbericht

Auswahl, Einrichtung und Betrieb von Rechnern und Komponenten bzgl. DOS
Antworten
Martin75
BIOS-Flasher
Beiträge: 391
Registriert: Mo 6. Jul 2015, 21:46

Dallas RTC Umbau - Erfahrungsbericht

Beitrag von Martin75 »

Hallo Forengemeinde,

da bei meinem Escom PC von 1994 nun auch die Batterie leer war und er das booten verweigerte musste der Dallas Chip repariert werden.

Zuerst habe ich mit einem Cuttermesser von oben her begonnen das Plastik wegzukratzen bis die Batterie frei war.

Danach mit einem Lötkolben mit sehr geringer Hitze um die Batterie herumfahren um das Plastik aufzuweichen aber NICHT so stark erhitzen dass es qualmt.

Das Material wird dabei bröselig und kann gut abgeschabt werden.

Dazwischen immer wieder probieren ob sich die Knopfzelle schon gelöst hat.

Das Ergebnis sieht so aus:
Siehe Anhang

Teil 2 folgt später
Dateianhänge
Dallas1.jpg
Dallas1.jpg (76.6 KiB) 524 mal betrachtet
Martin75
BIOS-Flasher
Beiträge: 391
Registriert: Mo 6. Jul 2015, 21:46

Re: Dallas RTC Umbau - Erfahrungsbericht

Beitrag von Martin75 »

Danach wurde ein Knopfzellenhalter angelötet und mit Heisskleber fixiert.

Nach dem einlegen einer neuen Batterie verlange der Rechner nach einem Bios-Passwort!
Dabei hatte ich nie eines vergeben.

Zu Glück gab es einen CLR PWD Jumper.
(Clear Password ) einmal kurz gesetzt und das passwort war gelöscht.

Ins BIOS kam ich aber nicht.
Der Rechner meldete sich immer das die Uhrzeit nicht korrekt sei und bot mir an mit F1 ins Setup zu gehen.
Aber nach drücken von F1 passierte nichts mehr. Ausser das der Cursor einfror.

Auch ein Clear CMOS per Jumper half nicht.

Mit oder ohne Festplatte brachte keine Änderung.

Zu guter Letzt hab ich ein floppy angeschlossen und davon bootete er.

Mit "date " die uhrzeit eingestellt und seitdem kann man wieder normal ins BIOS und einstellen (hdd Parameter z.b) und der PC läuft seitdem normal.

Vielleicht hilft dies jemand bei ähnlichen Problemen.
Dallas2.jpg
Dallas2.jpg (128.57 KiB) 510 mal betrachtet
S+M
DOS-Guru
Beiträge: 970
Registriert: Mo 10. Jun 2013, 17:04
Wohnort: BW

Re: Dallas RTC Umbau - Erfahrungsbericht

Beitrag von S+M »

Sauber! Da sieht man auch schön den internen Aufbaut des Moduls.
Benutzeravatar
redled
MemMaker-Benutzer
Beiträge: 91
Registriert: Mi 24. Mai 2006, 17:26

Re: Dallas RTC Umbau - Erfahrungsbericht

Beitrag von redled »

Ich habe heute ebenfalls die fest verlötetete RTC vom P55T2P4 aufgeschliffen, dann mit dem Lötkolben um der Batterie Kreise gezogen und anschließend die Batterie entfernt, die großen Kontaktflächen angeschliffen, Drähte angebracht und dann mit Epoxyd die großen Kontaktflächen wieder vergossen. Anschließend eine entlötete Halterung einer CR2032 seitlich versetzt angebracht, weil meine AWE32 sonst bei der RTC aufliegt. Die hat huckepack noch ein DB50-XG drauf. Etwas Klebeband aus dem Heizungsbereich verhindert ungewollten Kontakt mit dem Board. Sieht nicht schön aus, aber immerhin einfacher, als die ganze RTC ohne Schaden zu entlöten, einen Sockel aufzubringen und eine neue RTC dort rein zu machen. DENN dann passt die AWE wieder nicht mehr in den untersten Slot! Diese Lösung ist besser, weil die CR2032 Batterien viel billiger zu haben sind, als die ganze RTC (bei Reichelt etwa 12,00€).

Bild
.
Bild

Bild

Jetzt kann ich auch wieder D-Ram Timings einstellen und von Diskette booten =)
Asus-P/I-P55T2P4 + P233MMX, 128MB RAM
AWE32+8MB, Yamaha DB50-XG, S3 Trio64V+(miro)
MSDOS 6.22
S+M
DOS-Guru
Beiträge: 970
Registriert: Mo 10. Jun 2013, 17:04
Wohnort: BW

Re: Dallas RTC Umbau - Erfahrungsbericht

Beitrag von S+M »

Sehr schön!
Als Ersatz für das Klebeband kann ich auch Kapton empfehlen. Das ist sehr temperaturbeständig, dünn, isoliert perfekt und langlebig ist es auch noch.
Antworten