DOS 7.1 startet einige Programme nicht

Hier dürfen auch unregistrierte Gäste posten.
Boojakascha_

DOS 7.1 startet einige Programme nicht

Beitragvon Boojakascha_ » Mi 16. Mai 2018, 08:26

Hallo

Ich habe ein Problem mit DOS 7.1. Es startet einige Programme nicht. Konkret wird die Eingabetaste angenommen, aber auf der neuen Zeile blinkt lediglich der Cursor. Ich kann mir vorstellen, dass das Programm ohne Fenster öffnet.

Ich kann das Programm dann auch nicht mehr schliessen (Ctrl-C) und darum muss ich einen Force Quit machen (Ctr-Alt-Del).

Am häufigsten sind installer betroffen.

Darum habe ich auch schon versucht in config.sys ausnahmen zu definieren:
device=c:\windows\setver.exe
setver install.exe 6.22

Aber das hat nichts gebracht.

Früher habe ich mir herumgemogelt und solche installer immer über Windows 98 laufen lassen und bin dann einfach zurück zu DOS 7.1. Leider funktioniert das nicht immer...

Ich vermute der Grund wird trivial sein, weil ich mit Googeln nichts finde. Habt ihr eine Idee?
Benutzeravatar
mmworx
HELP.COM-Benutzer
Beiträge: 43
Registriert: Di 1. Mai 2018, 19:28
Wohnort: Mannheim

Re: DOS 7.1 startet einige Programme nicht

Beitragvon mmworx » Mi 16. Mai 2018, 09:19

Nenn mal das/ein betreffende(s) Programm.

Klingt eher so, als würde eine GUI erwartet und es ist schlecht programmiert, da ich soetwas aus Linux kenne.
Es muss ja nicht immer Strg+C sein, um ein Programm zu beenden.

Grüße
Boojakascha_

Re: DOS 7.1 startet einige Programme nicht

Beitragvon Boojakascha_ » Mi 16. Mai 2018, 09:47

Hallo mmworx

Danke für die Antwort.

Ein Beispiel wäre install.exe aus dem selbstextrahierenden sbbasic.exe, dem Treiber Paket für Creative Soundblaster 16. Aus dem selben Paket geht CTCU.exe nicht, welches plugandplay Eingenschaften einstellen würde.

Bei Spielen: Doom 1.19 Vollversion hat das Problem, 1.1 Shareware hat das Problem aber nicht....
Benutzeravatar
mmworx
HELP.COM-Benutzer
Beiträge: 43
Registriert: Di 1. Mai 2018, 19:28
Wohnort: Mannheim

Re: DOS 7.1 startet einige Programme nicht

Beitragvon mmworx » Mi 16. Mai 2018, 10:16

Witzig...
beides erst vorgestern installiert auf meinem "neuen" IBM 330.

Der Creative PnP Manager funktionierte bei mir mit MS-DOS 6.22 und später PC-DOS 7.0(1) problemlos.
Doom 1.9 läuft bei mir auch problemlos unter PC-DOS 7.0(1) (nach dem Update auf 1.9 ;-) ).

Ein Problem mit dem PnP Manager hatte ich jedoch, auch wenn der PC dafür schuld war. Die Karte wurde bei jedem 2. Start nicht erkannt und somit bei der Installation (falls die Karte nicht erkannt wurde) hing sich der Installer auf, doch ich sah das Text User Interface. Seit einem BIOS Update ist das Problem gegessen.

Von was für einem DOS sprechen wir hier überhaupt? Ich habe hier noch einen P1, welcher bei mir die gleiche Karte bekommen wird (CT2970). Da könnte ich mal ein anderes DOS probieren. Wenn du den Unterbau von Windows 95/98 meinst brauchst du den PnP Manager doch gar nicht, da es sich um PnP OS handelt! Hab eine CT4XXX iwas unter Windows 95... kein Problem. Läuft entsprechend auch bei DOS-Spielen.
Boojakascha_

Re: DOS 7.1 startet einige Programme nicht

Beitragvon Boojakascha_ » Mi 16. Mai 2018, 10:53

Wow, die Welt ist klein, ich habe die Versuche genau auch vorgestern durchgeführt.

Bei mir laufen die betroffenen Programme auf DOS 6.22 auch. Jedoch ist CTCU zickig. Es möchte sich nicht richtig bedienen lassen, schliesst Fenster unerwartet und erlaubt mir als Interrupt NUR 5. Ich kann keine anderen aussuchen, was schade ist.

Das Problemkind ist eine andere Festplatte mit Windows 98SE mit DOS 7.1. Das ist die Maschine auf welcher mache Executables einfach auf einem blinkenden Curser hängen bleiben. Das hängen bleiben von Executables ist mein Hauptproblem und ich bin generell am meisten daran interessiert es zu verstehen.

Ja, in 98SE läuft die Karte. Wenn ich sie in DOS 7.1 verwenden möchte, muss ich aber CTCM als device im config.sys anführen. Das geht für manche Spiele.... Normalerweise wäre CTCU dann noch im Autoexcec.bat. Jedoch verpfuscht mir dieses dort die plugandplay Einstellungen zu irgendwelchen Default Werten. Habe es darum rausgenommen.

Beim plugandplay bin ich ratlos... wenn ich bei 98SE im Gerätemanager einen Interrupt einstelle (zB 5), wird er dann wirklich 5 auf der Karte, oder "sucht" mein Computer nur bei 5? Ich wünschte ich hätte echte Jumper...
Benutzeravatar
mmworx
HELP.COM-Benutzer
Beiträge: 43
Registriert: Di 1. Mai 2018, 19:28
Wohnort: Mannheim

Re: DOS 7.1 startet einige Programme nicht

Beitragvon mmworx » Mi 16. Mai 2018, 11:24

Hi,
mit DOS als Unterbau werde ich dir nicht helfen können, doch ich weiß, dass du nicht 2 PnP Manager parallel betreiben darfst und somit für Windows 98 der Creative PnP Manager überflüssig ist. Er wird von Creative auch nicht für Windows 9x/Me bereitgestellt und der ist auch nur für ISA Karten.
Es gibt doch nichts besseres als ISA PnP Karten, wo die Systemressourcen mit dem BIOS ausgehandelt werden... naja OK wenn man ein PnP OS verwendet und nicht bei Anwendungen, wo man es denn definieren müsste, interessant wird, wenn man die Systemressourcen dann nicht kennt ;-) .

Achja Doom läuft bei mir noch nichtmal aus Win311 heraus. Es schließt sich einfach wieder. Wieso weshalb warum... kA.
Wundert mich also nicht, dass es mit späteren Windows Versionen erst recht nicht läuft. Ich hatte auch schon diverse Installer, welche den Dienst aus der Windows DOS-Shell verweigerten.
Ich spare mir da den Ärger und nutze einfach Kisten mit dem entsprechenden OS und habe meine Ruhe/Freude. Die alte Software ist nicht dafür gedacht.

"Beim plugandplay bin ich ratlos... wenn ich bei 98SE im Gerätemanager einen Interrupt einstelle (zB 5), wird er dann wirklich 5 auf der Karte, oder "sucht" mein Computer nur bei 5? Ich wünschte ich hätte echte Jumper..."

mMn nein. Das BIOS gibt das vor, aber ACHTUNG (Halbwissen bzw. nie probiert):
Es gibt in vielen moderneren BIOSen die Möglichkeit zu definieren, dass ein PnP OS verwendet wird. Hier kann wohl Einfluss auf die Systemressourcen über das OS genommen werden.
Boojakascha_

Re: DOS 7.1 startet einige Programme nicht

Beitragvon Boojakascha_ » Mi 16. Mai 2018, 11:39

Danke mmworx

Verstehe ich das richtig? Wenn CTCU mir nur erlaubt Interrupt 5 zu nehmen, dann ist das, weil der ISA Bus im BIOS den Interrupt 5 bekommen hat? Und ich müsste versuchen das im BIOS zu ändern? Ich hoffte ich könne die PnP Einstellungen mit CTCU selber nachhaltig ändern.

Ja, ich glaube auf meiner 98SE Platte laufen keine 2 PnP parallel. Ich hoffe es hat eine Fallunterscheidung ob ich im DOS 7.1 bin, oder im 98SE. Der Ton läuft in jedem Fall je nach Spiel auf beiden Systemen.

Ich habe die zweite Platte mit 6.22 aus Kompatibilitätsgründen. Dafür wurde ich belächelt, DOS 7.1 sei mindestens so kompatibel. Verstehe ich das richtig, dass dies nicht der Fall ist, und dass vieles bis 6.22 gut läuft aber dann einen Quantensprung ins Klo macht mit 7.1 ?
Boojakascha_

Re: DOS 7.1 startet einige Programme nicht

Beitragvon Boojakascha_ » Mi 16. Mai 2018, 11:44

Oh je, immer wenn DOS 7.1 steht, müsste 7.10 stehen. Bitte entschuldige.
Benutzeravatar
mmworx
HELP.COM-Benutzer
Beiträge: 43
Registriert: Di 1. Mai 2018, 19:28
Wohnort: Mannheim

Re: DOS 7.1 startet einige Programme nicht

Beitragvon mmworx » Mi 16. Mai 2018, 11:55

"Verstehe ich das richtig? Wenn CTCU mir nur erlaubt Interrupt 5 zu nehmen, dann ist das, weil der ISA Bus im BIOS den Interrupt 5 bekommen hat? Und ich müsste versuchen das im BIOS zu ändern? Ich hoffte ich könne die PnP Einstellungen mit CTCU selber nachhaltig ändern."
Ich spreche nur aus Erfahrung:
Ja, doch das wirst du nicht können. Bei ISA non-PnP muss das BIOS die Vorgaben der Karten fressen (ggf. kommen Fehlerausgaben bei Ressourcenüberschneidungen, oder der PC bootet nicht mehr (je nachdem welche Systemkomponenten betroffen ist).
Bei ISA PnP passiert das nicht (PnP wurde wohl darauf hin auch für das "späte" ISA impelmentiert -> stammt ursprünglich erst aus der PCI-Ära).

"Ich habe die zweite Platte mit 6.22 aus Kompatibilitätsgründen. Dafür wurde ich belächelt, DOS 7.1 sei mindestens so kompatibel. Verstehe ich das richtig, dass dies nicht der Fall ist, und dass vieles bis 6.22 gut läuft aber dann einen Quantensprung ins Klo macht mit 7.1 ?"

Das denke ich nicht. Wenn du bspw. mit F8 einfach in den DOS-Modus bootest, müsste DOOM usw. mMn eigentlich gehen (kannst es ja mal versuchen). Es wird wohl grundlegend mit Windows in die DOS-Shell das Problem geben, dass gewisse Software Probleme mit dem Ansprechen der Hardware bekommt. Nicht ohne Grund sollte man Damals nie aus Windows das BIOS flashen usw.

Ich persönlich finde es sowieso sinnfrei aus Windows DOS Anwendungen zu starten... wofür? Nur Ärger für nix.
Benutzeravatar
mmworx
HELP.COM-Benutzer
Beiträge: 43
Registriert: Di 1. Mai 2018, 19:28
Wohnort: Mannheim

Re: DOS 7.1 startet einige Programme nicht

Beitragvon mmworx » Mi 16. Mai 2018, 11:57

Boojakascha_ hat geschrieben:Oh je, immer wenn DOS 7.1 steht, müsste 7.10 stehen. Bitte entschuldige.

Deswegen dachte ich auch erst an PC-DOS :D.
Boojakascha_

Re: DOS 7.1 startet einige Programme nicht

Beitragvon Boojakascha_ » Mi 16. Mai 2018, 12:03

Ok, ich sehe das Problem, wir haben uns nicht verstanden.

Wenn ich sage, dass ich DOS 7.1 (meinte 7.10) laufen lasse, dann lasse ich DOS 7.10 laufen. Ich boote ins DOS um DOS zu verwenden. Ich gehe dafür nicht in die Windows 98SE Shell.

Die Programme laufen in DOS 7.10 (DOS mode, booted) nicht. In Shell in Windows laufen die Programme, welche laufen dürfen (Versionscheck) lustigerweise schon... Darum denke ich ja dass es ein Fenster/Anzeige Problem ist... Tragisch ist, wenn die Programm in 7.10 (gebootet) hängen bleiben, aber in Windows 98SE (Shell) eine Versionsabfrage machen...
Benutzeravatar
mmworx
HELP.COM-Benutzer
Beiträge: 43
Registriert: Di 1. Mai 2018, 19:28
Wohnort: Mannheim

Re: DOS 7.1 startet einige Programme nicht

Beitragvon mmworx » Mi 16. Mai 2018, 12:05

Boojakascha_ hat geschrieben:Ok, ich sehe das Problem, wir haben uns nicht verstanden.

Wenn ich sage, dass ich DOS 7.1 (meinte 7.10) laufen lasse, dann lasse ich DOS 7.10 laufen. Ich boote ins DOS um DOS zu verwenden. Ich gehe dafür nicht in die Windows 98SE Shell.

Die Programme laufen in DOS 7.10 (DOS mode, booted) nicht. In Shell in Windows laufen die Programme, welche laufen dürfen (Versionscheck) lustigerweise schon... Darum denke ich ja dass es ein Fenster/Anzeige Problem ist... Tragisch ist, wenn die Programm in 7.10 (gebootet) hängen bleiben, aber in Windows 98SE (Shell) eine Versionsabfrage machen...


Das werde ich nachher mit DOOM testen. Es müsste logischerweise genau anders herum sein.
Boojakascha_

Re: DOS 7.1 startet einige Programme nicht

Beitragvon Boojakascha_ » Mi 16. Mai 2018, 12:15

Genau... es ist zum verzweifeln :-(
Benutzeravatar
mmworx
HELP.COM-Benutzer
Beiträge: 43
Registriert: Di 1. Mai 2018, 19:28
Wohnort: Mannheim

Re: DOS 7.1 startet einige Programme nicht

Beitragvon mmworx » Mi 16. Mai 2018, 12:55

Boojakascha_ hat geschrieben:Genau... es ist zum verzweifeln :-(


Also ich sag es nur ungern aber das Problem mit DOOM liegt (nur) bei dir, denn:

In Windows 95 gestestet: Alles OK
In MS-DOS 7.00 getestet: Alles OK
In Windows 98SE getestet: Alles OK
in MS-DOS 7.10 getestet: Alles OK
Boojakascha_

Re: DOS 7.1 startet einige Programme nicht

Beitragvon Boojakascha_ » Mi 16. Mai 2018, 13:23

Habe ich mir gedacht.

Mir ist noch ein weiteres Programm in den Sinn gekommen, welches nicht startet: Windows!

Wenn ich in DOS 7.10
WIN

eingebe, kommt Windows nicht...

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast