DOS 6.22 con C: startet nicht

Hier dürfen auch unregistrierte Gäste posten.

DOS 6.22 con C: startet nicht

Beitragvon Martin » Di 11. Feb 2014, 20:22

hallo Leute :-)
wußte gar nicht, daß es im Jahr 2014 immer noch DOS-Veteranen gibt! Find ich klasse :-)

habe einfach mal DosForum.de eingetippt und bin daher bei Euch gelandet (freu)

So, nun mal zu meinem Problem.
Ich habe im Keller nen alten Karton gefunden mit einigen alten DOS-Spielen drinne. U.a. WC3 usw.
Nun dachte ich mir.........geil..........das waren Zeiten............damals! Habe daraufhin wieder echt Gelüste auf nen "alten" DOS6.22-Rechner! Wie früher!
Also gut, bei Schniebay MS-DOS 6.22 ersteigert (originalveschweißt mit Handbuch und OEM-CODE).
Ich habe einiges an alter Hardware rumzuliegen und dachte mir, ich bau mir nen DOS-Rechner zusammen, der da folgt:
Mainboard: Asus K7M mit BIOS von irgendwann 2000
CPU: AMD Athlon K7 600MHz Slot A
Ram: 2x 256 MB Infineon CL2 SDRAM
AOpen DVD-Laufwerk
Sound: Onboard (im BIOS auf Soundblaster eingestellt)
Festplatte: Western Digital 160GB (137 unformatted)
Floppy-Laufwerk
Netzteil: BeQuet 350 W

Ich habe den Rechner mit einer alten 6.22er Bootdisk gestartet und mit Fdisk partitioniert. Klar, der erkennt nur 2047MB.
Macht ja nix. Habe danach formatiert diese 2047 MB´s. Und dabei mit /s die Systemdateien auf die Festplatte übertragen.
Nun bootete ich den PC neu mit der originalen Dos6.22 Diskette 1, wonach gleich die Installationsroutine von Dos startet. Mit "Enter" installieren. Dabei empfhielt Dos, das Setup abzubrechen, da schon ein OS vorhanden wäre!?
Habe trotzdem das Setup durchgeführt! Also DOS ist nun auf der zuvor starfähig-gemachten Festplatte!
So, nun kommt`s: Der Pc startet partout nicht vom Laufwerk C:!!!!!!!!!!!!!!!
Dateien wie Config.sys bzw. autoexec.bat beinhalten beide die Gerätetreiber die notwendig sind, also welche die Installationsroutine von DOS geschrieben hat..............habe FDISK, mehrere Male durchgeführt und auch die Setup-Routine von DOS! .....................Geht nix!
Mit den Western.Digital-Tools die Festplatte Low-Level-formatiert und solche Scherze!
Ich weiß net mehr weiter!
Ich hoffe, Ihr könnt mir da weiterhelfen.............gerne auch direkt per E-Mail
Ziegfeld@gmx.net
Viele Grüße und bis dahin
Martin
 

Re: DOS 6.22 con C: startet nicht

Beitragvon freecrac » Di 11. Feb 2014, 21:11

Hallo.
Ist die Festplattte auf Master gejumpert?
Und wo hängt die genau dran?
Bei IDE gibt es anders als bei SATA ja gewisse Unterschiede.

Zuerst Hardware alles richtig einstellen und verkabeln, ggf. die Anschlüüse von Festplatte und DVD vertauschen wenn es so nicht klappt.

Dann auch im Bios alles perfekt einstellen.
Im Bios kann man dort ggf. auch andere Einstellungen in Bezug auf IDE finden?
(Ich kenne das Board leider nicht selber.)

....

Sonst: In das DVD-Laufwerk könnte man z.B auch eine Knoppix Live CD einlegen und booten und unter Linux es versuchen die Platte neu zu partitionieren. (Dafür im Bios auf DVD-Booten wechseln.)

Es sollte zumindest in den ersten 2047 MB eine primäre DOS-Partition zum booten mit FAT 16 formatiert vorhanden sein. Ich habe diesen Bereich auch schon einmal in 4 primäre Dos-Partitionen mit jeweils knapp 512 MB unterteilt und drei von diesen primären Partitionen unsichtbar gemacht, weil nur eine davon zur Zeit unter DOS sichtbar sein darf.
Unter Windows und unter Linux ist es möglich alle davon gleichzeitig sichtbar zu machen und Daten ohne Umwege auszutauschen. Hinter der/den primären Partition(en) können dann ja auch noch weitere logische Laufwerke in der erweiterten Partition mit der Größe von 2047 MB und Fat16 angelegt werden.

Zum Spielen alter DOS-Spiele könnte dein Rechner aber schon zu schnell sein.
Das Ding läuft bestimmt wie eine Rakete unter DOS.

Sonst könnte man sich auch einen 2 GB USB-Stick mit DOS bootfähig machen.
(So boote ich heute DOS auf meinem moderneren Intel-Core2quad-Rechner. Ich spiele damit aber keine DOS-Spiele.)

Dirk
freecrac
DOS-Guru
 
Beiträge: 861
Registriert: Mi 21. Apr 2010, 10:44
Wohnort: Hamburg Horn

Re: DOS 6.22 con C: startet nicht

Beitragvon Martin » Fr 14. Feb 2014, 17:47

hallo Dirk,
danke erstmal für Deine schnelle Antwort :-)
Die Festplatte ist als Master gejumpert und gleichzeitig als Single-Drive. Habe inzwischen Windows 98 SE installiert und da bootet die Festplatte einwandfrei und ohne Probleme. Einige DOS-Spielklassiker kann ich schon zocken (Wing Commander 4 usw.) Das funktioniert echt gut.

Habe auch mal ne andere Festplatte ausprobiert (WD 80 GB dieselbe Serie von 2003). Dos hat davon auch net gebootet.
Auch habe ich alle Steckverbindungen kontrolliert, alles bestens. CD-ROM-Laufwerk hängt allein am Secondary-IDE, die Festplatte am Primary-IDE-Anschluß. Das Rechner-BIOS erkennt auch alles einwandfrei. Einstellungen bezüglich des IDE-Controllers habe ich soweit möglich, alles auf "IDE-MODE" gestellt. Die Hauptplatine ist von 1999 und die letzt BIOS-Version ist vom August 2000. Naja, schaun mer mal, ob ich DOS doch noch irgendwie zum Laufen bringe.
Vielen Dank für die Hilfe und bis die Tage,macht`s gut
Grüße von Martin
Martin
 

Re: DOS 6.22 con C: startet nicht

Beitragvon olli64bremen » Sa 20. Mai 2017, 18:54

Hallo,

Jahre später gibt es auch mich, der einfach mal Bock auf Retro hat. Ich hatte auch das Problem, DOS 6.22 wollte einfach nicht starten. Meine Lösung, Du musst Deine Festplatte zwingend als Master am "ERSTEN" IDE Port des Mainboards anschliessen. Bei mir funktioniert es jetzt. Habe auch nur 24 Stunden gebastelt.

Viel Erfolg
LG Olli

olli64bremen@icloud.com
olli64bremen
 

Re: DOS 6.22 con C: startet nicht

Beitragvon Martin75 » Sa 20. Mai 2017, 20:26

Was auch oft vergessen wird:

Die Partition auf der die DOS systemdateien drauf sind (normalerweise die erste Primäre Partition, auf der ersten Festplatte) auf "aktiv" setzen.

Bei anderen Programmen nennt sich das auch "bootable".
Martin75
617K-Frei-Haber
 
Beiträge: 329
Registriert: Mo 6. Jul 2015, 20:46

Re: DOS 6.22 con C: startet nicht

Beitragvon Jigo » Mi 28. Jun 2017, 07:27

meine 2 cents. wenn du Dos installierst, wird das eh alles automatisch gemacht ;)
Benutzeravatar
Jigo
LAN Manager
 
Beiträge: 202
Registriert: Do 11. Aug 2016, 08:37
Wohnort: Luxemburg


Zurück zu Gästeforum

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 3 Gäste