Seite 1 von 1

512 MB RAM, beim Post nur 511 MB angezeigt

Verfasst: Mo 17. Jul 2017, 17:18
von Locutus
Hi Leute,

kurze Frage: Mein System hat 512 MB RAM verbaut, genauer 2x256mb DDR-SD-RAM (PC3200). Beim POST werden aber nur 511 angezeigt, genauer: 523264K.

Also fehlt genau 1 MB? Wo ist der hin? 1MB Memory Hole oder ähnliches gibt es im BIOS nicht als Option

Gruß
locutus

Re: 512 MB RAM, beim Post nur 511 MB angezeigt

Verfasst: Mo 17. Jul 2017, 17:27
von Solarstorm
VGA Shared Memory?

Re: 512 MB RAM, beim Post nur 511 MB angezeigt

Verfasst: Mo 17. Jul 2017, 17:31
von Locutus
Onboard VGA: disabled

Re: 512 MB RAM, beim Post nur 511 MB angezeigt

Verfasst: Mo 17. Jul 2017, 17:35
von Solarstorm
Video Bios Shadowed kopiert glaub auch was in den RAM. iirc
Falls das vorhanden ist.
Ansonst... kein Plan.

Re: 512 MB RAM, beim Post nur 511 MB angezeigt

Verfasst: Mo 17. Jul 2017, 19:21
von Martin75
Sind wahrscheinlich die 640k und der upper Memory.

Manche Boards zählen das nicht mit.

Re: 512 MB RAM, beim Post nur 511 MB angezeigt

Verfasst: Di 18. Jul 2017, 09:30
von Locutus
Das Video/System BIOS shadow Dings könnte es sein. Schaue ich mir heute Abend an. Benötigt man das unter Windows noch? Macht wahrscheinlich keinen Unterschied ob man das ein- oder ausschaltet, oder?

Re: 512 MB RAM, beim Post nur 511 MB angezeigt

Verfasst: Di 18. Jul 2017, 18:54
von Locutus
Also ich hab "Video BIOS Cacheable" und "System BIOS Cacheable" auf "Disabled" gesetzt. Bringt nix, immernoch nur 511 mb.

EDIT: Im Geräte-Manager von Windows 98 (SE) steht auch nur "511.0MB RAM".

Re: 512 MB RAM, beim Post nur 511 MB angezeigt

Verfasst: Fr 21. Jul 2017, 11:37
von drzeissler
Das dürfte das Hole von 15 auf 16MB sein. Check mal das Bios.

Re: 512 MB RAM, beim Post nur 511 MB angezeigt

Verfasst: Fr 21. Jul 2017, 14:16
von Locutus
@drzeissler: Sowas habe ich auch schon vermutet, aber die Option bietet das BIOS mir nicht an.

Ob die hart verdrahtet ist? Wäre ja dämlich... Kann man das testen?

EDIT: Folgendes Board AOpen i855GMEm-LFS BIOS 1.08

Re: 512 MB RAM, beim Post nur 511 MB angezeigt

Verfasst: Fr 21. Jul 2017, 19:40
von Dosenware
Ähm...
1MB Base Ram (640k+384k Rombereich) + 511MB extended Memory=512MB

manche Boards machen da einen Unterschied.

Re: 512 MB RAM, beim Post nur 511 MB angezeigt

Verfasst: Fr 21. Jul 2017, 23:05
von Locutus
Ja, aber der Geräte-Manager in Windows 98 sollte keinen Unterschied machen, korrekt? Der zeigt 511 MB, hab ich so noch nie gesehen.

Re: 512 MB RAM, beim Post nur 511 MB angezeigt

Verfasst: Sa 22. Jul 2017, 00:21
von Dosenware
Der Zeigt das an was er vom Bios gemeldet bekommt. (mit Umweg über diverse Treiber wie himem.sys, EMM386...)

Re: 512 MB RAM, beim Post nur 511 MB angezeigt

Verfasst: Sa 22. Jul 2017, 16:20
von Lotosdrache
Bei mir läuft ein Cusl2 mit Voodoo5-5500 und deaktivierter onboard-Grafik und ein Tusl2-C ohne onboard-Grafik. Beide haben 512 MB RAM und sind im BIOS identisch konfiguriert, was Memory Hole 15-16M (DISABLED), Video BIOS Shadow (ENABLED) betrifft.
Im Gerätemanager zeigt Win98SE beim Cusl2 511 MB an, beim Tusl2-C 512 MB.

Das fehlende Megabyte wird vermutlich tatsächlich von der onboard-Grafik als shared Memory beansprucht, auch wenn diese deaktiviert ist. Ein ähnliches Verhalten zeigen auch manch ältere SS7-Platinen mit Ali Aladdin 7 Chipsatz. Bisweilen läßt sich das halt nicht ganz abschalten. Leider :-(

Re: 512 MB RAM, beim Post nur 511 MB angezeigt

Verfasst: Sa 22. Jul 2017, 17:40
von Locutus
@Lotosdrache: Ich vermute, das wird es sein. Danke für die Infos. Beim i855GMEm-LFS habe ich die onboard-Grafik ebenfalls deaktiviert und die geringste Einstellung für den Framebuffer der onboard-GPU ist sogar 1 MB (wenn sie aktiviert ist) - würde also passen. Schade, aber kann man wohl nix machen.

Gruß
locutus