Problem Vergleich Microsoft Backup 6.0 auf DOS 6.2

DOS-Konfiguration, Anwendungen, Treiber und TSRs

Problem Vergleich Microsoft Backup 6.0 auf DOS 6.2

Beitragvon xmanuelfrankx » Mo 1. Aug 2016, 22:32

Hallo, zusammen.

Ich habe ein DOS 6.2 virtuell aufgesetzt, läuft per VMWare Player auch problemlos. Momentan verzweifle ich aber an MS Backup 6.0. Der Kompatibilitätstest scheint bei mir an immer derselben Stelle zu streiken. Der Test lässt sich starten, erstellt sogleich auch eine Liste an Dateien für eine Testsicherung. Anschließend werde ich zur Auswahl des Sicherungslaufwerks aufgefordert, auch hier klappt die Auswahl problemlos. Ich habe das System mit VMWare aufgesetzt und direkten Zugriff auf das Floppy-LW eingerichtet, welches ich mit 1,44MB Disketten in der Auswahl auch anwähle. Das Programm schließt die Testkonfiguration ab und fordert mich auf, die erste Diskette einzulegen. Anschließend startet die Sicherung bis die erste Diskette voll ist, scheinbar völlig problemlos. Ich werde aufgefordert, die nächste Diskette einzulegen, auf welcher die Testsicherung dann abgeschlossen wird. Im entsprechenden Fenster sind keinerlei aufgetretene Probleme ersichtlich. Nun wird der Kompatibilitätstest mit dem Vergleich der gesicherten Daten fortgesetzt und ich werde aufgefordert, die erste Diskette des Sicherungsdatensatzes einzulegen. Diese scheint auch erkannt und gelesen zu werden. Einzig und allein erscheint nun Fehler 1, korrigiert 1 im Status Fenster, das Programm für den Vergleich aber scheinbar aus, bis es an das Ende der ersten Diskette angelangt ist. Dann erscheint im Feld welches zuvor den Fortschritt des Vergleichs auf Diskette 1 angezeigt hat, "Einlegen Diskette 2", umgeben von synchron blinkenden Klammern. ABER: Das Diskettenlaufwerk ist noch immer gesperrt, da die Anwendung scheinbar noch darauf zugreift (Leuchtende Status LED am Floppy-LW). Stundenlanges Warten bringt keine Lösung, beenden lässt sich das Programm in diesem Zustand nicht. Wird die Diskette dann trotzdem entfernt, erscheint die Fehlermeldung "Kann defekte Diskette nicht lesen" und man ist gezwungen den Vergleich abzubrechen. Ab hier lässt sich das Programm auch wieder ganz normal steuern. Hab mir auch schon neue Disketten zugelegt, hatte aber keinen Effekt. Das Floppy-LW hat bisher und macht ansonsten aktuell auch keinerlei Probleme. Entsprechende Screenshot habe ich im Anhang beigefügt.

Ich habe im Moment so gar keinen Ansatz mehr, wie ich das Problem lösen könnte. Vielleicht hat hier jemand eine Idee, einen Ansatz oder gar eine Lösung?

Ich bin für alle Beiträge dankbar!
Dateianhänge
Kritischer Fehler.JPG
Kritischer Fehler.JPG (70.76 KiB) 3281-mal betrachtet
Sicherungsstatus.JPG
Sicherungsstatus.JPG (70 KiB) 3281-mal betrachtet
xmanuelfrankx
Solitärspieler
 
Beiträge: 10
Registriert: So 31. Jul 2016, 21:08

Re: Problem Vergleich Microsoft Backup 6.0 auf DOS 6.2

Beitragvon elianda » Mi 10. Aug 2016, 16:19

Das ist vollkommen normal, weil es prueft ob du die zweite Diskette eingelegt hast. Daher ist das Laufwerk auch im Zugriff.
In Realitaet kann man natuerlich trotzdem Diskette 1 herausnehmen und dann 2 einlegen, wobei es den Zustand 'keine Diskette in Laufwerk' gibt.
Da spielt dir wohl die Emulation einen Streich.
Diverse Retro-Computer vorhanden.
elianda
DOS-Übermensch
 
Beiträge: 1140
Registriert: Mi 31. Jan 2007, 19:04
Wohnort: Halle

Re: Problem Vergleich Microsoft Backup 6.0 auf DOS 6.2

Beitragvon xmanuelfrankx » Sa 13. Aug 2016, 21:05

Hallo,

danke erstmal für das Feedback. Ja, dass das Floppy-LW aktiv ist, sobald ich die zweite Diskette einlege, macht Sinn. Leider wird der Zugriff auf die erste Diskette nie beendet, das erzeugt dann bei Entnahme den besagten Fehler. Ebenso differiert hier das Verhalten von DOS: Beim Erstellen der Sicherungs-Disketten werde ich, sobald die erste Diskette voll ist, aufgefordert eine zweite einzulegen. In diesem Moment ist das Disketten-LW dann auch schon inaktiv und ich kann die Diskette problemlos entnehmen.

Inzwischen habe ich allerdings auch schon einige weitere Lösungsansätze ausprobiert, die mir durch den Kopf gegangen sind: Ich habe ein anderes Floppy-LW probeweise installiert (die haben ja auch schon ein paar Jahre auf dem Buckel und könnten Fehler aufweisen). Allerdings hatte das keinen sichtbaren Effekt, das Fehlerbild ist exakt identisch.

Ein weiterer Ansatz war, dass ich statt des physikalischen LW einfach ein durch VMWare simuliertes LW benutze. Hier hat sich das Fehlerbild dann dahingehend geändert, dass ich dann während des Vergleichsprozesses am Ende der ersten Diskette die gewünschte Aufforderung erhalte, eine weitere Diskette einzuelegen (siehe Screenshot anbei). Zumal während des Vergleichsprozesses der ersten Diskette die Fehlerrate extrem hoch ist. Ich wechsle dann die virtuelle Diskette, dann passiert allerdings gar nichts mehr. Der Timer läuft weiter, aber das wars dann auch.

Ist auch das ein Fehler, dessen Ursache in der VM zu suchen ist? Oder gibt es womöglich eine Ursache, die beide Effekte erklärt?

Für jeden Kommentar / Hinweis / Lösungsansatz im Voraus schonmal vielen Dank!
Dateianhänge
Vergleich Diskette 1.JPG
Vergleich Diskette 1.JPG (74.64 KiB) 3175-mal betrachtet
xmanuelfrankx
Solitärspieler
 
Beiträge: 10
Registriert: So 31. Jul 2016, 21:08

Re: Problem Vergleich Microsoft Backup 6.0 auf DOS 6.2

Beitragvon Martin75 » So 14. Aug 2016, 00:25

Kannst du die virtuelle Diskette auswerfen, bevor du eine andere virtuelle Disk einlegst?
Martin75
617K-Frei-Haber
 
Beiträge: 329
Registriert: Mo 6. Jul 2015, 20:46

Re: Problem Vergleich Microsoft Backup 6.0 auf DOS 6.2

Beitragvon xmanuelfrankx » Mo 15. Aug 2016, 20:35

Hallo,

ja, das geht. Beim Erstellen der Test-Sicherung funktioniert das auch einwandfrei, nur beim anschließenden Vergleich zwischen Original und Sicherung nicht mehr.
xmanuelfrankx
Solitärspieler
 
Beiträge: 10
Registriert: So 31. Jul 2016, 21:08

Re: Problem Vergleich Microsoft Backup 6.0 auf DOS 6.2

Beitragvon Martin75 » Mo 15. Aug 2016, 22:27

Evtl musst du die Disk entfernen, zur emulation wechseln, damit diese das das mitbekommt, und dann die neue Disk einlegen?

Wird die Emulation solange gestoppt, während du das Fester geöffnet hast wo du die virtuelle Disk auswählst?

Falls ja, könnte es sein dass das Programm vom Eject gar nix mitbekommt?
Martin75
617K-Frei-Haber
 
Beiträge: 329
Registriert: Mo 6. Jul 2015, 20:46

Re: Problem Vergleich Microsoft Backup 6.0 auf DOS 6.2

Beitragvon xmanuelfrankx » Di 16. Aug 2016, 19:45

Hallo,

ich bin nicht ganz sicher, ob ich Deine Frage richtig verstanden habe. Im Falle eines Wechsels gehe ich sowohl beim Erstellen der Sicherung als auch beim anschließenden Vergleich so vor, dass wenn die Meldung erscheint, ich das virtuelle Floppy-LW der VM aushänge, die virtuelle Disk Datei wechsle und anschließend das virtuelle Floppy LW wieder einhänge. Dann wechsele ich wieder in die VM und bestätige den gewechselten Datenträger. Im Falle der Sicherung wird diese dann auf der zweiten virtuellen Diskette abgeschlossen. Beim anschließenden Vergleich passiert leider gar nichts mehr. Bestätige ich den Wechsel ohne zuvor die virtuelle Diskette gewechselt zu haben, wird das registriert und ich erhalte eine Fehlermeldung, dass noch immer die erste Sicherungsdiskette eingelegt sei und ich die zweite einlegen soll.

Ergibt das irgendeinen Sinn?
xmanuelfrankx
Solitärspieler
 
Beiträge: 10
Registriert: So 31. Jul 2016, 21:08

Re: Problem Vergleich Microsoft Backup 6.0 auf DOS 6.2

Beitragvon Martin75 » Di 16. Aug 2016, 21:56

Meine Vermutung ist, dass das Programm überwacht ob eine Disk ins Laufwerk eingelegt ist/ gewechselt wird.
Die VM erkennt das als ständigen Zugriff.

Wie ist es bei einem echten PC?
Wenn das Programm auffordert die Diskette zu wechslen und du die disk entnimmst und die neue einlegst, macht das Programm dann automatisch weiter ohne dass du etwas bestätigen musst?

Wenn du nun in der VM das menü aufrufst um das Image auszuwerfen... wird die VM angehalten.
Du wirfst die Disktette aus und legst eine neue ein.. und wechselst zur VM.

Aber die VM hat das Signal (Diskettenlaufwerk leer) nicht mitbekommen, da es ja in der Zeit angehalten wurde.


Deswegen könntest du ausproboieren wenn das Programm zum Diskwechsel auffordert:

- Menü öffnen, Diskimage auswerfen.
- Zur VM wechseln
- nach einigen Sekunden wieder Menü öffnen und neues Image einlegen,
- Zur VM wechseln
Martin75
617K-Frei-Haber
 
Beiträge: 329
Registriert: Mo 6. Jul 2015, 20:46

Re: Problem Vergleich Microsoft Backup 6.0 auf DOS 6.2

Beitragvon xmanuelfrankx » Do 18. Aug 2016, 20:06

Hallo,

bei einem echten PC habe ich jetzt keinen Vergleichswert, da ich DOS wie gesagt nur auf einer VM am Laufen habe. Wenn ich allerdings das echte Disketten-LW verwendet anstatt des virtuellen bleibt der Vergleichsvorgang am Ende der ersten Diskette stehen, der Lesevorgang der Diskette allerdings nicht, sodass die Diektte nicht ordnungsgemäß ausgeworfen werden kann (siehe ursprüngliches Posting).

Den Vorgang mit Auswerfen in die VM wechseln dann einhägen und erneut in die VM wechseln habe ich ausprobiert, ledier ohne sichtbaren Effekt.

Zwei Dinge scheinen mir aber an dieser Stelle noch erwähnenswert: Ich denke nicht, dass die VM während des aus- und einhängens angehalten wird, da der Timer der während des Prozesses in MSBACKUP läuft, weiterläuft. Würde die VM angehalten müsste meiner Meinung nach auch dieser Timer stehen bleiben. Bei einem Diskettenwechsel oder CD-Wechsel würde bei einem echten PC ja auch nicht das Betriebssystem angehalten, sodass das aus meiner laienhaften Sicht auch nicht zwingend erforderlich ist, oder?

Dann wären da noch die virtuellen Disketten: Bei jedem neu erzeugten und gemountetem Diskettenimage meldet das Backup-Programm einen Fehler in der Formatierung und scheint diesen auch dann ordnungsgemäß zu beheben, daher hielt ich das bisher nicht für erwähnenswert. Vielleicht verbirgt sich hier aber noch ein wichtiger Hinweis?
Dateianhänge
Diskettenformatierung inkompatibel.JPG
Diskettenformatierung inkompatibel.JPG (70.1 KiB) 2682-mal betrachtet
xmanuelfrankx
Solitärspieler
 
Beiträge: 10
Registriert: So 31. Jul 2016, 21:08

Re: Problem Vergleich Microsoft Backup 6.0 auf DOS 6.2

Beitragvon Martin75 » Do 18. Aug 2016, 23:27

Hmm , dann bin ich mit meinem Latein am Ende..

schon mal eine andere VM ausprobiert?
Martin75
617K-Frei-Haber
 
Beiträge: 329
Registriert: Mo 6. Jul 2015, 20:46

Re: Problem Vergleich Microsoft Backup 6.0 auf DOS 6.2

Beitragvon xmanuelfrankx » Fr 19. Aug 2016, 21:54

Hallo,

nein, habe ich noch nicht. Wecleh wäre empfehlenswert?
xmanuelfrankx
Solitärspieler
 
Beiträge: 10
Registriert: So 31. Jul 2016, 21:08

Re: Problem Vergleich Microsoft Backup 6.0 auf DOS 6.2

Beitragvon Martin75 » Fr 19. Aug 2016, 22:47

kommt auf das Host-System an..

bei Windows:
Virtualbox
VM Ware
VirtualPC (läuft glaub ich nicht mehr unter neueren systemen als XP)
PC Em wäre auch einen blick wert

unter linux hab ich virtualbox am laufen.
Martin75
617K-Frei-Haber
 
Beiträge: 329
Registriert: Mo 6. Jul 2015, 20:46

Re: Problem Vergleich Microsoft Backup 6.0 auf DOS 6.2

Beitragvon Martin75 » Fr 19. Aug 2016, 23:06

Habs eben unter Linux mit Virtualbox getestet, läuft.

Konnte deine Fehlermeldungen nachvollziehen.

1. die Disketten werden bei mir auch zuerst formatiert.

2. überprüft das Programm ob es den Diskwechsel automatisch erkennt, hier meckert es immer es sei eine Disk eingelegt.
(hab das Laufwerk A manuell konfiguriert (1.44 MB)

3. beim Wiederherstellen (nachdem Disk 1 gelesen worden ist) kommt kein Pop-up Fenster wo man auf "fortsetzen" drücken muss.
aber im Hauptfenster blinkt "Disk2 einlegen".

entfernt man hier das Image bricht das Programm mit einem Lesefehler ab.

wechselt man von einem Image direkt zum anderen liest das Programm automatisch weiter und beendet den Test erfolgreich.
Martin75
617K-Frei-Haber
 
Beiträge: 329
Registriert: Mo 6. Jul 2015, 20:46

Re: Problem Vergleich Microsoft Backup 6.0 auf DOS 6.2

Beitragvon xmanuelfrankx » So 21. Aug 2016, 12:45

Hallo,

ich denke, dann werde ich das mal mit Virtual PC ausprobieren. Die letzte Version lief übrigens bis einschl. Win 7. Da das Wirtssystem in meinem Fall XP MCE 2005 ist, wird das auch kein Problem.

Hab ich das jetzt richtig verstanden: Unter der Linux VM ergab sich bei direktem Zugriff der VM auf das Floppy-LW derselbe Fehler, bei der Variante mit virtuellem Floppy-LW aber nicht, solange Du direkt von einem Disketten-Image zum nächsten wechselst?
xmanuelfrankx
Solitärspieler
 
Beiträge: 10
Registriert: So 31. Jul 2016, 21:08

Re: Problem Vergleich Microsoft Backup 6.0 auf DOS 6.2

Beitragvon Martin75 » So 21. Aug 2016, 15:44

Nein, ich hab immer mit virtuellen Disketten gearbeitet.

Beim direkten wechseln von einem Image zum anderen hat es funktioniert.

Werfe ich die virtuelle Diskette aus, kommt es zum Lesefehler.

Ein echtes Diskettenlaufwerk hat der PC nicht mehr (könnte höchstens ein USB-Floppy anstecken)
Martin75
617K-Frei-Haber
 
Beiträge: 329
Registriert: Mo 6. Jul 2015, 20:46

Nächste

Zurück zu Software

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast