Laute CD-Laufwerke unter DOS - Abhilfe mit CDBeQuiet!

Re: Laute CD-Laufwerke unter DOS - Abhilfe mit CDBeQuiet!

Beitragvon Kurt Steiner » Di 7. Jun 2011, 16:48

Cool jetzt gehen auch Werte unter 1200 bei meinem Laufwerk aber leider nimmt er sie dann nicht weiter, außer 600 !!!

Werte 75, 150, 300 haben keinen Einfluss und bekommen die gleichen Werte wie 600 bzw. sogar 1200 !
Mir ist aufgefallen, dass nicht mit jeder CD das Programm arbeiten kann, ich hatte von Ripper 1CD drinn,
da ging es nicht, jetzt ist andere CD drinn und es geht.

1800 - 10.75x Speed - 83,75 Punkte:
1800.jpg
1800.jpg (106.11 KiB) 2270-mal betrachtet


600 - 14,35x Speed - 131,34 Punkte:
600.jpg
600.jpg (106.88 KiB) 2271-mal betrachtet


1200 - 18,62x Speed - 171,30 Punkte:
1200.jpg
1200.jpg (107.43 KiB) 2271-mal betrachtet






PS: Kleiner Schreibfehler:

Example:
If you wanted to set a CD speed of 4x (1x = 150 kb/s)
for a slave CD-ROM on your secondary IDE channel,
the following command will do:
cdbq -p2 -dm -s600


Müsste: cdbq -p2 -ds -s600 heißen ! Da es Slave ist.
Benutzeravatar
Kurt Steiner
DOS-Guru
 
Beiträge: 884
Registriert: Mo 14. Dez 2009, 08:05
Wohnort: Leipzig

Re: Laute CD-Laufwerke unter DOS - Abhilfe mit CDBeQuiet!

Beitragvon Locutus » Di 7. Jun 2011, 21:10

Hey Kurt,

danke für die Infos, insbesondere den Tippfehler. In der Version 1.0 werde ich das verbessern.

Dein Laufwerk zeigt ja komische Werte. Bei 1800 nur 10.75x? War das mit CDBQ 0.7b anders? Wenn ja würd' ich dich bitten, das nochmal genau nachzuvollziehen. Denn eigentlich darf sich in den Ergebnissen nichts unterscheiden zwischen den Versionen...

Hast du mit Rohlingen oder mit "echten" CDs getestet? (Besser ist mit echten, unverkratzten, vollbeschriebenen CDs)

Gruß
locutus
Benutzeravatar
Locutus
Site Admin
 
Beiträge: 1353
Registriert: Mo 7. Mär 2005, 23:33
Wohnort: NRW

Re: Laute CD-Laufwerke unter DOS - Abhilfe mit CDBeQuiet!

Beitragvon Kurt Steiner » Mi 8. Jun 2011, 06:19

Hallo locutus,

jupp werde heute Abend noch mal beide Versionen testen.

Ist eine originale Spiele-CD gewesen. Wie gesagt mit der Spiele-CD 1 von Ripper hatte ich dieselben Werte als wenn ich keine CD-Bremse drinne hätte.

Ich nehme heute Abend wieder die eine CD und werde 4 Tests machen einmal 1200 mit beiden Versionen und dann noch mal mit 1800. Bin mal gespannt ob die sich unterscheiden. Den ersten Test auf Seite 4 habe ich mit einer anderen CD gemacht die nicht größer als 510 MB war, deswegen fehlen da auch die Seek-Werte.
Benutzeravatar
Kurt Steiner
DOS-Guru
 
Beiträge: 884
Registriert: Mo 14. Dez 2009, 08:05
Wohnort: Leipzig

Re: Laute CD-Laufwerke unter DOS - Abhilfe mit CDBeQuiet!

Beitragvon Kurt Steiner » Mi 8. Jun 2011, 16:14

Oki hier nochmal die Werte: Test-CD war die erste Spiele-CD (org.) von Blade Runner. Bei jeden Neueinstellen der Geschwindigkeit wurde gebootet.

V.07 - 1200 - 19.74x Speed - 213,63 Punkte:
V7_1200.jpg
V7_1200.jpg (106.14 KiB) 2243-mal betrachtet


V.09 - 1200 - 19.85x Speed - 227,30 Punkte:
V9_1200.jpg
V9_1200.jpg (105.64 KiB) 2243-mal betrachtet


V.07 - 1800 - 10.81x Speed - 98,94 Punkte:
V7_1800.jpg
V7_1800.jpg (105.44 KiB) 2243-mal betrachtet


V.09 - 1800 - 10.81x Speed - 98,98 Punkte:
V9_1800.jpg
V9_1800.jpg (105.54 KiB) 2243-mal betrachtet



PS: Andere Werte die getestet wurden waren, 2150, 2400, 3600 alle Werte keinen nennenswerten Effekt !
Benutzeravatar
Kurt Steiner
DOS-Guru
 
Beiträge: 884
Registriert: Mo 14. Dez 2009, 08:05
Wohnort: Leipzig

Re: Laute CD-Laufwerke unter DOS - Abhilfe mit CDBeQuiet!

Beitragvon Locutus » Mi 8. Jun 2011, 16:26

Danke für die Tests! Die sind jetzt etwas aufschlußreicher. Gut auch, daß du jedesmal rebootet hast.

Die Ergebnisse von 0.7 vs 0.9 unterscheiden sich nicht, was schonmal gut ist. D.h., daß der neue Code aus 0.9b gut funktioniert. Ich hatte erst befürchtet, daß es da Unterschiede geben könnte.

Außerdem sieht man an der ersten Grafik recht deutlich, daß dein Laufwerk bei ~24x Schluß macht.

Mich wundert jetzt etwas, daß nur Werte zwischen 1800 und 2150 einen Effekt haben, aber was soll's. Manche Laufwerke sind da akkurater und andere interpretieren den Wert relativ ungenau bis gar nicht. Mein TEAC-Laufwerk nimmt die Werte ziemlich genau, das liegt aber vielleicht auch daran, daß TEAC bei ihrem eigenen DOS-CD-ROM-Treiber schon von Hause aus eine Geschwindigkeitsbegrenzung vorgesehen hat (über einen Parameter), welche anscheinend dieselbe Methode nutzt wie CDBQ.

Kannst du evtl. noch die Firmware-Revision posten?

Danke

locutus
Benutzeravatar
Locutus
Site Admin
 
Beiträge: 1353
Registriert: Mo 7. Mär 2005, 23:33
Wohnort: NRW

Re: Laute CD-Laufwerke unter DOS - Abhilfe mit CDBeQuiet!

Beitragvon Kurt Steiner » Mi 8. Jun 2011, 16:34

Also 600/1800 habe verschiedene Werte, ich komme mit den 1800 am besten und geht auch ganz gut !

Model number: TSSTcorpDVD-ROM SH-D162D
Firmware rev.: SB03

(Steht schon in deiner Liste drinne.)

ich werde mal noch andere Werte im laufe der Zeit testen. Mal schauen ob ich die Kiste unter 10x bekomme.

1200 hat keinen EFFEKT !!!

Ohne CDBremse - 19.75x Speed - 213,83 Punkte:
ohne_bremse.jpg
ohne_bremse.jpg (106.29 KiB) 2239-mal betrachtet
Benutzeravatar
Kurt Steiner
DOS-Guru
 
Beiträge: 884
Registriert: Mo 14. Dez 2009, 08:05
Wohnort: Leipzig

Re: Laute CD-Laufwerke unter DOS - Abhilfe mit CDBeQuiet!

Beitragvon Locutus » Di 28. Feb 2017, 18:12

Hallo Leute,

wollte euch nur wissen lassen, dass es nach 6 Jahren jetzt wieder eine neue Version gibt. :-)

Grundsätzlich hat sich nur geändert, dass jetzt kein DPMI-Speicher mehr benötigt wird.

Gruß
locutus
Benutzeravatar
Locutus
Site Admin
 
Beiträge: 1353
Registriert: Mo 7. Mär 2005, 23:33
Wohnort: NRW

Vorherige

Zurück zu Programmierung

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast