Seite 1 von 1

pci soundcard config

BeitragVerfasst: Mo 8. Okt 2007, 14:24
von tikbalang
i can't get pci soundcards to work with an ecs l4s5mg mobo. the mobo has onboard soundchip sis7012 (sis ac97) but it has no dos drivers. i already disabled onboard sound and some functions in the bios to free irq.

i tried these cards:

realtek als300
esstech es1980
creative ct4810
creative ct1373

the funny thing is the drivers install fine in dos and windows, with no errors in the control panel. the dos utilities that came with the drivers also play sound and show no errors.

when i try to play sound, mplayer or soundrec starts playing but no sound comes out. in dos, any app that uses sound can't see the sound card/drivers or crashes the pc.

it seems only the onboard sound works in windows and linux but i need this board for dos. please direct me to any info or other forums that can help me solve this problem. thank you.

BeitragVerfasst: Di 9. Okt 2007, 13:48
von elianda
CT4810 should be one of the SB-Live cards?
The DOS driver gives you at most an emulation of a virtual standard DOS-ISA soundcard.
f.e. Soundblaster 16

So try this:
Load the emulation driver. This should give you something like a virtual SoundBlaster. Check if the environment variable BLASTER which stores the virtual hardware ressources provided by the emulation driver is set correctly. Maybe the driver or driver-installation sets this variable.
Try if it works with some program supporting the emulated soundcard, like:
MPXPLay, OpenCubicPlayer oder XTC-Play etc...
start with Soundblaster [Pro].

But note, that an emulation driver cannot emulate real hardware to a 100% identity. There might be programs that work and others that don't (even crash).

Oh and checkout if http://dosbox.sourceforge.net/news.php?show_news=1
is sufficient for your application.