Soundblaster 128 PCI unter MS Dos 6.2

Hier dürfen auch unregistrierte Gäste posten.
Vobexo

Soundblaster 128 PCI unter MS Dos 6.2

Beitragvon Vobexo » Mo 22. Okt 2012, 20:04

Hallo,

Ich wollte meinen Uralt PC P-233MMX als Retro DOS Game Machine wiederbeleben und meinem Sohnemann mal zeigen wie Spiele vor 25 Jahre ausgesehen haben. Der PC Läuft soweit gut, aber ich bekomme keinen Sound aus der Soundblaster 128 PCI.

Ich habe keinen reinen DOS Treiber für diese Karten (hab eine CT4700 und eine CT4810) gefunden.

Wenn man Googel glauben darf unterstützen die Karten kein reines DOS, sondern nur Dos-Emu?

Auf einem anderen PC mit Win 98 laufen beide problemlos. Vom PC Bios bekommt die Karte keinen IRQ zugewiesen , deshalb wird Sie wohl von den Gamesetup´s nicht als Soundblaster erkannt. Set Blaster hatte ich auch gesetzt (a220 i5 D1 P330 T2) bringt aber auch nix.

IRQ Zuweisung über BIOS geht auch nicht direkt bei diesem PC man kann bei manuell nur zwischen PCI/ISA PNP und Legacy ISa wechseln)

Gibt es ne Möglichkeit diese Karte(n) unter reinem MS Dos 6.2 zum laufen zu bringen?
Benutzeravatar
Dosenware
DOS-Gott
Beiträge: 3626
Registriert: Mi 24. Mai 2006, 20:29

Re: Soundblaster 128 PCI unter MS Dos 6.2

Beitragvon Dosenware » Mo 22. Okt 2012, 20:37

PCI Soundkarten benötigen Treiber für die Ressourceneinstellung und funktionieren auch dann unter DOS eher schlecht als recht.
Für Dos würde ich dir daher eine ISA-Soundkarte empfehlen (z.b. eine ES1868 - die sind sehr unproblematisch).

PS. Für deine Karten sollte der Dostreiber im Windows 9x Treiber mit enthalten sein.
drzeissler
DOS-Gott
Beiträge: 3159
Registriert: Mo 8. Feb 2010, 16:59

Re: Soundblaster 128 PCI unter MS Dos 6.2

Beitragvon drzeissler » Mo 22. Okt 2012, 21:46

Ich hatte das auch mal versucht mit einer PC-Karte, aber davon kann ich ganz klar abraten.
Zumal die PCI-Soundblasterkarten unter Dos zwingend EMM386 brauchen. Also haben Spiele
und Demos die nur Himem brauchen keinen Sound.

Wenn Du unter Dos was machen willst dann ganz klare Empfehlung:

1. Kein 233er MMX sondern < 200 Mhx damit der TP-Bug nicht auftritt
2. Mindestens eine ISA-Soundkarte (SBPro/SB16 oder sonstwas) unter Dos ein Musthave: Gravis Ultrasound !
3. Eine Grafikkarte die unter Dos Vesa unterstützt bspw. eine GF3-Ti200 (nur maximal 256 Farben unter Win3x) oder halt ne ordentliche Matrox MGA-400-32MB, gehen tut auch eine Voodoo3.

Doc
Zuletzt geändert von drzeissler am So 28. Okt 2012, 14:30, insgesamt 1-mal geändert.
CPU: 486 DX2/66 MOBO: SNI-D882 RAM: 3x16MB - FDD: 3,5" 1,44MB HDD: 6,4GB Seagate ISA(1): Audican32Plus PCI(1): 3com TX 905 OS: MsDos622 - Win95a - WinNT 3.51
Gast

Re: Soundblaster 128 PCI unter MS Dos 6.2

Beitragvon Gast » So 28. Okt 2012, 13:37

So, ich hab verschieden Treiber von der Creative Webseite für die PCI 128 runtergeladen und auf dem Win Pc installiert, aber keiner der Treiber hatte einen DOS Treiber (Sowas wie Sbini.exe) mit dabei.

Anscheinend hat die128 PCI keinen DOS Support.

Werde versuchsweise mal mit Dos-Treiber anderer Soundblasterkarten versuchen, hab das was in den untiefen des Web gefunden und wer mal rumprobiern.

MFG Vobexo

P.S. was ist den der TP-Bug?
Benutzeravatar
philscomputerlab
DOS-Übermensch
Beiträge: 1275
Registriert: Fr 1. Okt 2010, 10:40
Wohnort: Australien
Kontaktdaten:

Re: Soundblaster 128 PCI unter MS Dos 6.2

Beitragvon philscomputerlab » So 28. Okt 2012, 13:44

Hi!

Die Karte ist glaube ich ein AudioPCI, nachdem Creative Ensoniq gekauft hat.

Probier mal die Treiber hier in meinem Artikel:

http://vogons.zetafleet.com/viewtopic.p ... t=audiopci

Trotzdem empfehle ich dir eine ISA Sound Blaster. Die PCI Karten sind gut fuer neuere Spiele, aber gerade bei den ganz alten gibt es viele Probleme.
drzeissler
DOS-Gott
Beiträge: 3159
Registriert: Mo 8. Feb 2010, 16:59

Re: Soundblaster 128 PCI unter MS Dos 6.2

Beitragvon drzeissler » So 28. Okt 2012, 14:29

http://en.wikipedia.org/wiki/Runtime_error_200

Unter Dos gehen die SB-PCI Karten nur mit EMM386, sonst gibt es keinen Ton.
CPU: 486 DX2/66 MOBO: SNI-D882 RAM: 3x16MB - FDD: 3,5" 1,44MB HDD: 6,4GB Seagate ISA(1): Audican32Plus PCI(1): 3com TX 905 OS: MsDos622 - Win95a - WinNT 3.51

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 12 Gäste