CF Karte nicht bootfähig? Alles probiert....

Auswahl, Einrichtung und Betrieb von Rechnern und Komponenten
Benutzeravatar
YangMimpi
617K-Frei-Haber
Beiträge: 333
Registriert: So 8. Dez 2013, 18:31
Wohnort: Leipzig
Kontaktdaten:

CF Karte nicht bootfähig? Alles probiert....

Beitragvon YangMimpi » Mi 25. Dez 2013, 22:20

Hi,

ich bin mit meinem Latein am Ende. Habe mir ja für meinen DOS-Rechner eine 2GB CF Karte inkl. IDE-CF Adapter zugelegt. Diese wird auch als Festplatte im Bios erkannt und kann auch unter DOS ganz normal genutzt werden. Sämtliche Versuche die Karte als Stand-Alone Laufwerk (steckt sowie als einziges Master am IDE Anschluss) zum Laufen zu bekommen sind gescheitert (Karte wird im Bios als 2GB HDD erkannt!)

sys d: bzw. fdsik d: brachten keinen Erfolg - Formatierung bzw. Systemdateienübertragung funktioniert zwar, aber als einzige Platte wird die Karte von der DOS Installationsdiskette weiterhin nicht erkannt.

Jemand noch eine Idee? :-(
Benutzeravatar
Dekay
Kommandozeilenfetischist
Beiträge: 153
Registriert: Mi 15. Jun 2005, 09:32
Wohnort: München

Re: CF Karte nicht bootfähig? Alles probiert....

Beitragvon Dekay » Mi 25. Dez 2013, 22:28

Leider gibt es auch CF-Adapter, die nicht bootfähig sind. Welcher ist es denn?
Benutzeravatar
philscomputerlab
DOS-Übermensch
Beiträge: 1273
Registriert: Fr 1. Okt 2010, 10:40
Wohnort: Australien
Kontaktdaten:

Re: CF Karte nicht bootfähig? Alles probiert....

Beitragvon philscomputerlab » Mi 25. Dez 2013, 22:39

Die CF Karte ist Nagelneu gell?

Probiere bitte folgendes:

Boote mit einer Boot Diskette. Dann gib ein: FDISK/MBR

Sie sollte jetzt booten.

Ich hatte dieses Problem mit so ziemlich jeder neuen CF Karte und auch SATA HDDs > SATA PCI Karten :)

Wenn das nicht funktioniert musst du etwas mehr ueber deinen PC, welches OS, was sonst noch alles drinnen ist berichten.

PS: Das verstehe ich aber nicht ganz:

aber als einzige Platte wird die Karte von der DOS Installationsdiskette weiterhin nicht erkannt.

aber:

und kann auch unter DOS ganz normal genutzt werden.
Benutzeravatar
YangMimpi
617K-Frei-Haber
Beiträge: 333
Registriert: So 8. Dez 2013, 18:31
Wohnort: Leipzig
Kontaktdaten:

Re: CF Karte nicht bootfähig? Alles probiert....

Beitragvon YangMimpi » Mi 25. Dez 2013, 22:51

Ja, die CF-Karte ist nagelneu bzw. war. Bis jetzt habe ich da ein paar Backupdaten drauf (zum Test)

Betriebssystem: DOS 6.22

Anschlüsse: Also an einer IDE Schnittstelle am Board hängt eine 20GB Festplatte (Master) und ein Hitachi-LW (Slave). Am 2. IDE Anschluss hängt als Master nur der CF-Adapter.

Solange die Festplatte ( mit Dos 6.22 drauf) hochfährt und Dos normal startet, wird die CF Karte als Laufwerk D (2.Festplatte) genutzt. Ich kann beliebig Daten hin und her kopieren oder auch Spiele drauf installieren o.ä. Im Bios wird die CF Karte sowieso immer als 2GB Festplatte erkannt. Sobald ich aber die IDE-Festplatte abklemme oder einfach im BIOS "abschalte", wird die CF Karte nicht mehr im Betriebssystem(!!) als Laufwerk/Festplatte erkannt. Im Bios steht sie unverändert weiter drin als 2GB Festplatte als Secondary Master.

Hmm, also so wie es ausschaut, scheint der Adapter in der Tat nicht bootfähig zu sein. Ist ein 0815 Teil aus der Bucht.
Benutzeravatar
philscomputerlab
DOS-Übermensch
Beiträge: 1273
Registriert: Fr 1. Okt 2010, 10:40
Wohnort: Australien
Kontaktdaten:

Re: CF Karte nicht bootfähig? Alles probiert....

Beitragvon philscomputerlab » Mi 25. Dez 2013, 23:09

Nicht bootfaehige adapter das gibt es nicht. Das manche defekt sind, das kann aber schon sein. Aber deine scheint zu funktionieren.

Ok bitte probiere folgendes:

Entferne bitte (oder einfach abstecken) die 20GB und Hitachi.

Schliess die CF Karte an den Primaeren IDE an und jumpere den adapter auf Master.

Boote mit einer DOS 6.22 bootdisk.

Starte FDISK

Mache die partition auf der CF Karte atktiv / oder checke ob sie das schon ist.

gibt dann ein

sys c:

fdisk /mbr

Entferne die floppy und starte den PC neu.

Er sollte jetzt booten.
Benutzeravatar
YangMimpi
617K-Frei-Haber
Beiträge: 333
Registriert: So 8. Dez 2013, 18:31
Wohnort: Leipzig
Kontaktdaten:

Re: CF Karte nicht bootfähig? Alles probiert....

Beitragvon YangMimpi » Do 26. Dez 2013, 00:07

Wow. Es funktioniert!!

Offenbar scheint der Adapter sehr zickig darauf zu reagieren, was im BIOS noch an HDD da ist bzw, was noch am Kabel hängt - er wollte nämlich partout, obwohl richtig gejumpert, nicht funktionieren wenn zb. ein CD-ROM als Slave mit dran hängt oder auch nur eine Festplatte im Bios noch eingetragen war, die gar nicht mehr am Board/Kabel hängt.

Egal, der Adapter hängt jetzt alleine am Master 0 und das CD-LW alleine am Master 1 und bootet ohne Probleme :-)

Ich danke dir für den Tipp!
Benutzeravatar
philscomputerlab
DOS-Übermensch
Beiträge: 1273
Registriert: Fr 1. Okt 2010, 10:40
Wohnort: Australien
Kontaktdaten:

Re: CF Karte nicht bootfähig? Alles probiert....

Beitragvon philscomputerlab » Do 26. Dez 2013, 00:13

Hey super :)

Ja mit CF Karten habe ich schon viel Erfahrung gemacht.

Nochmal: Der Adapter is total passiv. Da ist gar keine Logik oder sonstwas drauf. CF Karten sind ja 100% IDE kompatibel. Wenn also was nicht funktioniert dann liest es woanders.

Aber schoen dass die Kiste jetzt rennt :)

Unter DOS kann nur eine Platte aktiv markiert sein. Vielleicht hat es damit was zu tun...

Ich halte es bei meinen System immer simpel. Eine einzelne CF als C: und ein CD-ROM auf D: so funktioniert es eigentlich immer.

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 5 Gäste