[erledigt] GA-7IXE Parallelport deaktivieren und SBA testen?

Auswahl, Einrichtung und Betrieb von Rechnern und Komponenten

[erledigt] GA-7IXE Parallelport deaktivieren und SBA testen?

Beitragvon Lotosdrache » Mo 19. Jun 2017, 16:32

Ich schaffe es einfach nicht, beim GA-7IXE den Parallelport komplett abzuschalten.
- Obwohl im BIOS unter Integrated Peripherals alles, was mit parallelen und seriellen Schnittstellen zu tun hat, deaktiviert ist, erkennt Win98SE immer noch einen ECP-Parallelport und blockiert dadurch IRQ7 und DMA1.
- Deaktivieren der Schnittstelle im Gerätemanager schaufelt den IRQ7 auch nicht frei.
- Entfernt man den Port aus dem Hardwareprofil, wird er nach einem Neustart wieder erkannt und neu eingerichtet.
- Habe eben das BIOS von F3 auf F7 (neueste) aktualisiert, brachte aber keine Besserung.

Da in den Rechner eine GUS rein soll, hätte ich gerne so viel wie möglich frei, zumal ich den Parallelport eh nicht brauche. Habe schon erfolglos verschiedene Einstellungen von "Auto" über "Standardmodus" bis "Disabled" ausprobiert.
Beim GA-6BXC und CUSL2 ist das kein Problem und funktioniert wie gewünscht.

Wer weiß Rat?

Immerhin wurde laut Everest Home 2.20 durch das BIOS-Update der AGP 2x-Modus und das Sideband-Addressing (SBA) des AGP aktiviert. Letzteres soll ja laut elinda dazu führen, daß das System einfriert.

Wie kann ich testen, ob das SBA wirklich funktioniert?

Übrige Komponenten:
Athlon "Pluto K75" 1000 MHz
192 MB SD-RAM PC100 CL2 Micron Technology
ATi Rage Pro Turbo 2xAGP (nur vorübergehend bis das System wie gewünscht läuft, dann kommt eine Voodoo5-5500 rein)
6 GB HDD Western Digital
DVD-RW LG(?)
3,5" 1,44 MB Floppy Sony
350 W NT Seasonic

Win98SE ohne Patches
Win98Plus!
AMD-Chipatztreiber für GA-7IXE von Gigabyte-HP
ATi-Ragetreiber 4.11.2560 von ehemaliger ATi-HP
Zuletzt geändert von Lotosdrache am Do 22. Jun 2017, 11:02, insgesamt 1-mal geändert.
Ich werde mich von keinem einzzzigen Prozzzessor trennen.
Jedoch lockt es mich beinahe, ihn Dir zu überlassen, nur um zu sehen, wie er Dich in den Wahnsinn treibt :twisted:

Meine Begehren
Lotosdrache
Kommandozeilenfetischist
 
Beiträge: 168
Registriert: Sa 9. Jan 2016, 23:25

Re: Wie beim GA-7IXE Parallelport deaktivieren und SBA teste

Beitragvon tom4DOS » Mo 19. Jun 2017, 19:47

Ich habe das gleiche Verhalten bei meinem K6-III-System, der Parallelport lässt sich nicht komplett deaktivieren, ebenso wie der USB-Host. Unter Win98 habe ich die dazugehörigen Geräte deaktiviert, dann sollte Win98 denen keine Ressourcen mehr zuordnen. Keine Ahnung, warum das bei Dir nicht funktioniert (Rechner nach deaktivieren mal neu gestartet?).
tom4DOS
BIOS-Flasher
 
Beiträge: 371
Registriert: Do 24. Feb 2011, 17:20
Wohnort: München

Re: Wie beim GA-7IXE Parallelport deaktivieren und SBA teste

Beitragvon Lotosdrache » Di 20. Jun 2017, 00:18

tom4DOS hat geschrieben:Rechner nach deaktivieren mal neu gestartet?

Mehr als nur einmal.
Das seltsame ist, daß nach der Deaktivierung im Gerätemanager der IRQ 7 in der Übersicht des Systemprogramms "Systeminformationen" nicht mehr auftaucht. Als ob es ihn überhaupt nicht geben würde. Die Liste springt von IRQ 6 gleich zu IRQ 8. Die freien IRQs 3, 4 und 5 werden dagegen mit der Belegungsart "(frei)" angezeigt.

Ich werde die GUS einfach mal einbauen und versuchen, ihr den IRQ 7 zuzuweisen. Mal sehen was dann passiert.
Ich werde mich von keinem einzzzigen Prozzzessor trennen.
Jedoch lockt es mich beinahe, ihn Dir zu überlassen, nur um zu sehen, wie er Dich in den Wahnsinn treibt :twisted:

Meine Begehren
Lotosdrache
Kommandozeilenfetischist
 
Beiträge: 168
Registriert: Sa 9. Jan 2016, 23:25

Re: Wie beim GA-7IXE Parallelport deaktivieren und SBA teste

Beitragvon Lotosdrache » Di 20. Jun 2017, 16:10

Jetzt ist auch die GUS PnP drinnen
Bild

und wie befürchtet, gibt es Ressourcenkonflikte mit den DMAs und IRQs, solange der PP aktiviert ist
Bild Bild

Nach der Deaktivierung im Gerätemanager, sieht die Sache wesentlich besser aus als befürchtet. Die GUS PnP kann DMA 1 und IRQ 7 belegen. Damit kann ich erst einmal leben, auch wenn es im Gerätemanager nicht ganz perfekt aussieht.
Bild Bild
:-D :-D :-D :-D :-D :-D :-D

Und hier noch der Zwischenstand vom Aufbau
Bild

Als Graka dient noch die Radeon 8500. Es fehlen noch der SCSI-Controller DC-2974 PCI Dawicontrol (liegt hier rum), die NIC Allied Telesis AT-2701FTX, das Nakamichi und evtl. ein IDE ZIP-LW und eine PowerVR PCX2 oder Rage II+DVD.

So, jetzt ist es Zeit für den AGP-Stabilitätstest...

EDIT

Hat zufällig jemand die IRQ-Sharing-Tabelle für dieses Board? Das würde mir den Einbau der übrigen PCI-Karten sehr erleichtern!
Ich werde mich von keinem einzzzigen Prozzzessor trennen.
Jedoch lockt es mich beinahe, ihn Dir zu überlassen, nur um zu sehen, wie er Dich in den Wahnsinn treibt :twisted:

Meine Begehren
Lotosdrache
Kommandozeilenfetischist
 
Beiträge: 168
Registriert: Sa 9. Jan 2016, 23:25

Re: Wie beim GA-7IXE Parallelport deaktivieren und SBA teste

Beitragvon Lotosdrache » Do 22. Jun 2017, 11:01

Lotosdrache hat geschrieben:Immerhin wurde laut Everest Home 2.20 durch das BIOS-Update der AGP 2x-Modus und das Sideband-Addressing (SBA) des AGP aktiviert. Letzteres soll ja laut elinda dazu führen, daß das System einfriert.

Wie kann ich testen, ob das SBA wirklich funktioniert?

Mit PCI List 2.22 konnte ich nun die Register auslesen und sehen, daß sowohl auf Seiten des Chipsatzes als auch auf Seiten der Radeon 8500 das SBA aktiviert ist :-) Der Final Reality 1.01 Benchmark lief ohne Probleme durch, auch der integrierte AGP-Test :peanutbutterjellytime: Vermutlich beziehen sich die Infos zum SBA, die im Netz stehen, auf eine ältere BIOS-Version. Ich sehe sie jedenfalls mal als veraltet an.

Habe auch mal eine ISA Plug'n'Pray Netzwerkkarte von 3Com zusammen mit der GUS PnP eingebaut. Ergebnis: GUS 5+7, ISA NIC 9. Dann noch eine PCI NIC von Realtek und den PCI SCSI-Controller von Dawicontrol dazu:
AGP 11
GUS PnP 5+7
ISA NIC 9
SCSI 10
PCI NIC 3
USB 3

Nach meinen ganzen Versuchen mit den Karten in verschiedenen Slots, ergibt sich etwa folgendes Schema für das IRQ-Sharing:
AGP + PCI3
PCI1 + onboard USB (bevorzugtes Sharing)
PCI2
PCI4 + PCI5
ISA1
ISA2
onboard IDE

Dabei hat der onboard USB Controller seinen IRQ bevorzugt mit dem PCI Slot 1 geteilt, aber sobald die IRQs überbelegt waren, teilte er ihn sich unter Windows 98SE (!) immer mit der PCI Netzwerkkarte, egal ob die nun im PCI Slot 1, 2, 3 oder 4 steckte.
Die Vorkonfiguration durch das BIOS wich laut der System Configurationstablle mit zunehmender Belegung immer mehr von der späteren Konfiguration durch Win98SE ab, vermutlich weil das BIOS die ISA PnP-Karten bei der Verteilung nicht berücksichtigt hat.

Werde meine Karten jetzt so anordnen:
AGP: ganz klar eine Grafikkarte
PCI1: (frei)
PCI2: Dawicontrol DC-2974 SCSI-Controller
PCI3: (frei)
PCI4: Allied Telesis AT-2701FTX NIC
PCI5: (frei)
ISA1: GUS PnP (hier hat sie mehr Abstand zum Netzteilkabel und die Lüftungslöcher im Boden bleiben auch etwas freier)
ISA2: (frei)
So muß keine Karte oder onboard Komponente ihren IRQ teilen :cheesygrin:
Ich werde mich von keinem einzzzigen Prozzzessor trennen.
Jedoch lockt es mich beinahe, ihn Dir zu überlassen, nur um zu sehen, wie er Dich in den Wahnsinn treibt :twisted:

Meine Begehren
Lotosdrache
Kommandozeilenfetischist
 
Beiträge: 168
Registriert: Sa 9. Jan 2016, 23:25


Zurück zu Hardware

Wer ist online?

Mitglieder in diesem Forum: Bing [Bot] und 2 Gäste